summaryrefslogtreecommitdiffstats
path: root/recipes-containers/docker-compose/python3-docker-compose_1.16.1.bb
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@siemens.com>2017-09-15 13:13:00 +0200
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-09-15 15:21:18 -0400
commitd16d4acc6059d05d94a4e319b801ce0272f17dd9 (patch)
treee0ea9532b2f9996eeb9d219a42f288939ad671e2 /recipes-containers/docker-compose/python3-docker-compose_1.16.1.bb
parente83556a3f4633e91be4bb107fb7663c5282a924a (diff)
downloadmeta-virtualization-d16d4acc6059d05d94a4e319b801ce0272f17dd9.tar.gz
python3-docker-compose: add version 1.16.1 + dependencies
This requires some packages as well as the pypi.bbclass from meta-python. It uses Python 3 as I don't think it makes sense to use Python 2 anymore. Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers/docker-compose/python3-docker-compose_1.16.1.bb')
-rw-r--r--recipes-containers/docker-compose/python3-docker-compose_1.16.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-containers/docker-compose/python3-docker-compose_1.16.1.bb b/recipes-containers/docker-compose/python3-docker-compose_1.16.1.bb
new file mode 100644
index 00000000..50e76b7e
--- /dev/null
+++ b/recipes-containers/docker-compose/python3-docker-compose_1.16.1.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Multi-container orchestration for Docker"
2HOMEPAGE = "https://www.docker.com/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=435b266b3899aa8a959f17d41c56def8"
5
6SRC_URI += "file://0001-Allow-newer-versions-of-requests.patch"
7
8inherit pypi setuptools3
9
10SRC_URI[md5sum] = "8dcadf09143600fcb573b43f446c8f9a"
11SRC_URI[sha256sum] = "fb46a6a2c4d193a3ff1e4d7208eea920b629c81dc92257c87f3f93095cfb0bdf"
12
13RDEPENDS_${PN} = "\
14 ${PYTHON_PN}-cached-property \
15 ${PYTHON_PN}-certifi \
16 ${PYTHON_PN}-chardet \
17 ${PYTHON_PN}-colorama \
18 ${PYTHON_PN}-docker \
19 ${PYTHON_PN}-docker-pycreds \
20 ${PYTHON_PN}-dockerpty \
21 ${PYTHON_PN}-docopt \
22 ${PYTHON_PN}-enum \
23 ${PYTHON_PN}-idna \
24 ${PYTHON_PN}-jsonschema \
25 ${PYTHON_PN}-pyyaml \
26 ${PYTHON_PN}-requests \
27 ${PYTHON_PN}-six \
28 ${PYTHON_PN}-texttable \
29 ${PYTHON_PN}-urllib3 \
30 ${PYTHON_PN}-websocket-client \
31 "