summaryrefslogtreecommitdiffstats
path: root/recipes-containers/criu
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-08-27 15:07:22 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-08-27 15:07:22 -0400
commitb94455174264240bf8519e4148ea5f1fb38d55c6 (patch)
treeff11ead10d653c941b59a68295a0ef8117ec449d /recipes-containers/criu
parent5d8233a69979af36105ad5ec978a1a4c686a2148 (diff)
downloadmeta-virtualization-b94455174264240bf8519e4148ea5f1fb38d55c6.tar.gz
protobuf: fix build/source split for libdir fix
Ensure that we modify the libdir in the build directory, not the source directory, to respect the splitting of source and build. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers/criu')
-rw-r--r--recipes-containers/criu/protobuf_2.5.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-containers/criu/protobuf_2.5.0.bb b/recipes-containers/criu/protobuf_2.5.0.bb
index fc84cb72..0e11ff48 100644
--- a/recipes-containers/criu/protobuf_2.5.0.bb
+++ b/recipes-containers/criu/protobuf_2.5.0.bb
@@ -39,7 +39,7 @@ do_compile_ptest() {
39 # Add the location of the cross-compiled header and library files 39 # Add the location of the cross-compiled header and library files
40 # which haven't been installed yet. 40 # which haven't been installed yet.
41 cp "${B}/protobuf.pc" "${B}/${TEST_SRC_DIR}/protobuf.pc" 41 cp "${B}/protobuf.pc" "${B}/${TEST_SRC_DIR}/protobuf.pc"
42 sed -e 's|libdir=|libdir=${PKG_CONFIG_SYSROOT_DIR}|' -i "${S}/${TEST_SRC_DIR}/protobuf.pc" 42 sed -e 's|libdir=|libdir=${PKG_CONFIG_SYSROOT_DIR}|' -i "${B}/${TEST_SRC_DIR}/protobuf.pc"
43 sed -e 's|Cflags:|Cflags: -I${S}/src|' -i "${B}/${TEST_SRC_DIR}/protobuf.pc" 43 sed -e 's|Cflags:|Cflags: -I${S}/src|' -i "${B}/${TEST_SRC_DIR}/protobuf.pc"
44 sed -e 's|Libs:|Libs: -L${B}/src/.libs|' -i "${B}/${TEST_SRC_DIR}/protobuf.pc" 44 sed -e 's|Libs:|Libs: -L${B}/src/.libs|' -i "${B}/${TEST_SRC_DIR}/protobuf.pc"
45 export PKG_CONFIG_PATH="${B}/${TEST_SRC_DIR}" 45 export PKG_CONFIG_PATH="${B}/${TEST_SRC_DIR}"