summaryrefslogtreecommitdiffstats
path: root/recipes-containers/criu
diff options
context:
space:
mode:
authorDavid Nyström <david.nystrom@enea.com>2012-12-06 10:55:37 +0100
committerDavid Nyström <david.nystrom@enea.com>2012-12-07 15:32:30 +0100
commit02e4046656f5805751d654e8808500fb884f6fce (patch)
treea17b2a67a8282de8e591ba53271c52f8559c270b /recipes-containers/criu
parentfec87b05983111010770da1109354cb588cc52af (diff)
downloadmeta-virtualization-02e4046656f5805751d654e8808500fb884f6fce.tar.gz
Added CRIU recipe
Signed-off-by: David Nyström <david.nystrom@enea.com> Reviewed-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers/criu')
-rw-r--r--recipes-containers/criu/criu_git.bb29
-rw-r--r--recipes-containers/criu/files/0001-Fixed-hardcoding.patch47
2 files changed, 76 insertions, 0 deletions
diff --git a/recipes-containers/criu/criu_git.bb b/recipes-containers/criu/criu_git.bb
new file mode 100644
index 00000000..878827f8
--- /dev/null
+++ b/recipes-containers/criu/criu_git.bb
@@ -0,0 +1,29 @@
1SUMMARY = "CRIU"
2DESCRIPTION = "Checkpoint/Restore In Userspace, or CRIU, is a software tool for Linux operating system. Using this tool, you can freeze a running application (or part of it) and checkpoint it to a hard drive as a collection of files. You can then use the files to restore and run the application from the point it was frozen at. The distinctive feature of the CRIU project is that it is mainly implemented in user space"
3HOMEPAGE = "http://criu.org"
4SECTION = "console/tools"
5LICENSE = "GPLv2"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=12920dfe6b35a0758155f0e62878b366"
8
9SRCREV = "d81c9a4618db2f618bdb8e207b7f0fec631c7142"
10PR = "r0"
11PV = "0.2+git${SRCPV}"
12
13SRC_URI = "git://git.criu.org/crtools.git;protocol=git \
14 file://0001-Fixed-hardcoding.patch"
15
16DEPENDS += "protobuf-c-native protobuf-c"
17
18S = "${WORKDIR}/git"
19
20EXTRA_OEMAKE += "ARCH=${TARGET_ARCH} WERROR=0"
21
22do_compile () {
23 oe_runmake
24}
25
26do_install () {
27 mkdir -p ${D}/${bindir}
28 install -m 755 ${S}/crtools ${D}/${bindir}/crtools
29} \ No newline at end of file
diff --git a/recipes-containers/criu/files/0001-Fixed-hardcoding.patch b/recipes-containers/criu/files/0001-Fixed-hardcoding.patch
new file mode 100644
index 00000000..5ff0a78d
--- /dev/null
+++ b/recipes-containers/criu/files/0001-Fixed-hardcoding.patch
@@ -0,0 +1,47 @@
1From 32c6c037a6de0a0972e16949ebb64ffebb5b7bcc Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?David=20Nystr=C3=B6m?= <david.nystrom@enea.com>
3Date: Wed, 28 Nov 2012 15:07:27 +0100
4Subject: [PATCH] Fixed hardcoding
5
6---
7 Makefile.inc | 24 ++++++++++++------------
8 1 file changed, 12 insertions(+), 12 deletions(-)
9
10diff --git a/Makefile.inc b/Makefile.inc
11index 722cbfc..3ae693e 100644
12--- a/Makefile.inc
13+++ b/Makefile.inc
14@@ -11,18 +11,18 @@ else
15 endif
16 export E Q
17
18-FIND := find
19-CSCOPE := cscope
20-TAGS := ctags
21-RM := rm
22-LD := ld
23-HEXDUMP := hexdump
24-CC := gcc
25-ECHO := echo
26-NM := nm
27-AWK := awk
28-SH := sh
29-MAKE := make
30+FIND ?= find
31+CSCOPE ?= cscope
32+TAGS ?= ctags
33+RM ?= rm
34+LD ?= ld
35+HEXDUMP ?= hexdump
36+CC ?= gcc
37+ECHO ?= echo
38+NM ?= nm
39+AWK ?= awk
40+SH ?= sh
41+MAKE ?= make
42
43 # Additional ARCH settings for x86
44 ARCH ?= $(shell echo $(uname_M) | sed -e s/i.86/i386/ -e s/sun4u/sparc64/ \
45--
461.7.9.5
47