summaryrefslogtreecommitdiffstats
path: root/recipes-containers/criu/files/0005-pycriu-skip-dependency-check-during-build.patch
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2024-03-02 13:56:03 -0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2024-03-15 17:17:19 +0000
commitcd11ca9de3ea8d1c1efaabe0a7d9c4daea56a15b (patch)
tree55263dce656a30149cc4e706f88965a2534a59ac /recipes-containers/criu/files/0005-pycriu-skip-dependency-check-during-build.patch
parent9b4acf5185324c244b62aa9e9791fa4afa0bcdb5 (diff)
downloadmeta-virtualization-cd11ca9de3ea8d1c1efaabe0a7d9c4daea56a15b.tar.gz
criu: fix pycriu build of wheel
Inherit python_setuptools_build_meta instead of setuptools3, as this is the build-backend declared in the pyproject.toml We seem to need python3-protobuf-native as a DEPENDS, but then the dependency check complains because our version in meta-python is python3-protobuf_4.25.bb Workaround this (for now?) by telling python3 -m build to --skip-dependency-check This allows criu to _build_. Whether it is functional and proper is a different story. Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Diffstat (limited to 'recipes-containers/criu/files/0005-pycriu-skip-dependency-check-during-build.patch')
-rw-r--r--recipes-containers/criu/files/0005-pycriu-skip-dependency-check-during-build.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-containers/criu/files/0005-pycriu-skip-dependency-check-during-build.patch b/recipes-containers/criu/files/0005-pycriu-skip-dependency-check-during-build.patch
new file mode 100644
index 00000000..c293131d
--- /dev/null
+++ b/recipes-containers/criu/files/0005-pycriu-skip-dependency-check-during-build.patch
@@ -0,0 +1,30 @@
1From 2ec745ac11357e3243ef1f23f817c276518ce7cb Mon Sep 17 00:00:00 2001
2From: Tim Orling <tim.orling@konsulko.com>
3Date: Sat, 2 Mar 2024 13:48:54 -0800
4Subject: [PATCH] pycriu: --skip-dependency-check during build
5
6It complains about needing protobuf<4, python3-protobuf is 4.25 in meta-python
7
8Signed-off-by: Tim Orling <tim.orling@konsulko.com>
9---
10 lib/Makefile | 4 ++--
11 1 file changed, 2 insertions(+), 2 deletions(-)
12
13diff --git a/lib/Makefile b/lib/Makefile
14index b5f147482..e3faa7a06 100644
15--- a/lib/Makefile
16+++ b/lib/Makefile
17@@ -66,11 +66,11 @@ ifeq ($(PIP_BREAK_SYSTEM_PACKAGES),0)
18 $(E) " Consider using PIP_BREAK_SYSTEM_PACKAGES=1 make install"
19 else
20 $(E) " INSTALL " pycriu
21- $(Q) $(PYTHON) -m build --no-isolation --wheel --outdir $(PEP517_WHEEL_PATH) $(PEP517_SOURCE_PATH) $(PEP517_BUILD_OPTS)
22+ $(Q) $(PYTHON) -m build --no-isolation --wheel --skip-dependency-check --outdir $(PEP517_WHEEL_PATH) $(PEP517_SOURCE_PATH) $(PEP517_BUILD_OPTS)
23 endif
24 else
25 $(E) " BUILD " pycriu
26- $(Q) $(PYTHON) -m build --no-isolation --wheel --outdir $(PEP517_WHEEL_PATH) $(PEP517_SOURCE_PATH) $(PEP517_BUILD_OPTS)
27+ $(Q) $(PYTHON) -m build --no-isolation --wheel --skip-dependency-check --outdir $(PEP517_WHEEL_PATH) $(PEP517_SOURCE_PATH) $(PEP517_BUILD_OPTS)
28 $(E) " INSTALL " pycriu
29 #nativepython3 -m installer ${INSTALL_WHEEL_COMPILE_BYTECODE} --interpreter "${USRBINPATH}/env ${PEP517_INSTALL_PYTHON}" --destdir=${D} ${PEP517_WHEEL_PATH}/*.whl
30