summaryrefslogtreecommitdiffstats
path: root/recipes-containers/criu/criu_git.bb
diff options
context:
space:
mode:
authorJianchuan Wang <jianchuan.wang@windriver.com>2015-09-07 13:29:57 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-09-08 10:01:24 -0400
commit34a127f3c52550f6ec903e22356a5d772a32bbed (patch)
treee5c8544ebfb84fd9b74eb8c91e71d41dbe8e8cd0 /recipes-containers/criu/criu_git.bb
parent25228032779e492ce08eb3697cb2a68934fef383 (diff)
downloadmeta-virtualization-34a127f3c52550f6ec903e22356a5d772a32bbed.tar.gz
criu: upgrade 1.4 -> 1.6
Signed-off-by: Jianchuan Wang <jianchuan.wang@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers/criu/criu_git.bb')
-rw-r--r--recipes-containers/criu/criu_git.bb30
1 files changed, 23 insertions, 7 deletions
diff --git a/recipes-containers/criu/criu_git.bb b/recipes-containers/criu/criu_git.bb
index 2b8921fa..48bcdc27 100644
--- a/recipes-containers/criu/criu_git.bb
+++ b/recipes-containers/criu/criu_git.bb
@@ -13,16 +13,17 @@ EXCLUDE_FROM_WORLD = "1"
13 13
14LIC_FILES_CHKSUM = "file://COPYING;md5=5cc804625b8b491b6b4312f0c9cb5efa" 14LIC_FILES_CHKSUM = "file://COPYING;md5=5cc804625b8b491b6b4312f0c9cb5efa"
15 15
16SRCREV = "bda033e1e91ac5b86afd0a9fdb9fcdd581da6185" 16SRCREV = "4c5b23e52c1dc4e3fbbc7472b92e7b1ce9d22f02"
17PR = "r0" 17PR = "r0"
18PV = "1.4+git${SRCPV}" 18PV = "1.6+git${SRCPV}"
19 19
20SRC_URI = "git://git.criu.org/crtools.git;protocol=git \ 20SRC_URI = "git://github.com/xemul/criu.git;protocol=git \
21 file://0001-criu-Fix-toolchain-hardcode.patch \ 21 file://0001-criu-Fix-toolchain-hardcode.patch \
22 file://0002-criu-Skip-documentation-install.patch \ 22 file://0002-criu-Skip-documentation-install.patch \
23 file://0001-criu-Change-libraries-install-directory.patch \
23 " 24 "
24 25
25COMPATIBLE_HOST = "(x86_64|arm).*-linux" 26COMPATIBLE_HOST = "(x86_64|arm|aarch64).*-linux"
26 27
27DEPENDS += "protobuf-c-native protobuf-c" 28DEPENDS += "protobuf-c-native protobuf-c"
28 29
@@ -35,8 +36,9 @@ S = "${WORKDIR}/git"
35# 36#
36EXTRA_OEMAKE_arm += "ARCH=${CRIU_BUILD_ARCH} WERROR=0" 37EXTRA_OEMAKE_arm += "ARCH=${CRIU_BUILD_ARCH} WERROR=0"
37EXTRA_OEMAKE_x86-64 += "ARCH=${TARGET_ARCH} WERROR=0" 38EXTRA_OEMAKE_x86-64 += "ARCH=${TARGET_ARCH} WERROR=0"
39EXTRA_OEMAKE_aarch64 += "ARCH=${TARGET_ARCH} WERROR=0"
38 40
39EXTRA_OEMAKE_append += "SBINDIR=${sbindir} LIBDIR=${libdir} INCLUDEDIR=${includedir}" 41EXTRA_OEMAKE_append += "SBINDIR=${sbindir} LIBDIR=${libdir} INCLUDEDIR=${includedir} PIEGEN=no"
40EXTRA_OEMAKE_append += "LOGROTATEDIR=${sysconfdir} SYSTEMDUNITDIR=${systemd_unitdir}" 42EXTRA_OEMAKE_append += "LOGROTATEDIR=${sysconfdir} SYSTEMDUNITDIR=${systemd_unitdir}"
41 43
42CFLAGS += "-D__USE_GNU -D_GNU_SOURCE" 44CFLAGS += "-D__USE_GNU -D_GNU_SOURCE"
@@ -44,12 +46,26 @@ CFLAGS += "-D__USE_GNU -D_GNU_SOURCE"
44# overide LDFLAGS to allow criu to build without: "x86_64-poky-linux-ld: unrecognized option '-Wl,-O1'" 46# overide LDFLAGS to allow criu to build without: "x86_64-poky-linux-ld: unrecognized option '-Wl,-O1'"
45export LDFLAGS="" 47export LDFLAGS=""
46 48
49export BUILD_SYS
50export HOST_SYS
51
52inherit setuptools
53
54do_compile_prepend() {
55 rm -rf ${S}/protobuf/google/protobuf/descriptor.proto
56 ln -s ${PKG_CONFIG_SYSROOT_DIR}/usr/include/google/protobuf/descriptor.proto ${S}/protobuf/google/protobuf/descriptor.proto
57}
58
47do_compile () { 59do_compile () {
48 oe_runmake 60 oe_runmake
49} 61}
50 62
51do_install () { 63do_install () {
52 oe_runmake DESTDIR="${D}" install 64 oe_runmake PREFIX=${exec_prefix} LIBDIR=${libdir} DESTDIR="${D}" install
53} 65}
54 66
55FILES_${PN} += "${systemd_unitdir}/" 67FILES_${PN} += "${systemd_unitdir}/ \
68 ${libdir}/python2.7/site-packages/ \
69 ${libdir}/pycriu/ \
70 ${libdir}/crit-0.0.1-py2.7.egg-info \
71 "