summaryrefslogtreecommitdiffstats
path: root/recipes-containers/cri-o/cri-o_git.bb
diff options
context:
space:
mode:
authorMingli Yu <Mingli.Yu@windriver.com>2019-07-26 17:10:51 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-08-12 10:49:04 -0400
commita12a6d922eac3c91a40355454849723c042cfb66 (patch)
tree4bd3fd8761680f6d4eff1367cac95bf42c322a8c /recipes-containers/cri-o/cri-o_git.bb
parent91c23e6a9c3adf2d9493b9263d114b40d8b3ec1b (diff)
downloadmeta-virtualization-a12a6d922eac3c91a40355454849723c042cfb66.tar.gz
cri-o: skip it when depends not found
cri-o depends on ostree, libselinux and libseccomp and we should check if the layer which provides these recipes exist or not before go on. Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/cri-o/cri-o_git.bb')
-rw-r--r--recipes-containers/cri-o/cri-o_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-containers/cri-o/cri-o_git.bb b/recipes-containers/cri-o/cri-o_git.bb
index c27aef78..b0c0ce44 100644
--- a/recipes-containers/cri-o/cri-o_git.bb
+++ b/recipes-containers/cri-o/cri-o_git.bb
@@ -42,6 +42,28 @@ RDEPENDS_${PN} = " \
42 cni \ 42 cni \
43 " 43 "
44 44
45python __anonymous() {
46 msg = ""
47 # ERROR: Nothing PROVIDES 'libseccomp' (but /buildarea/layers/meta-virtualization/recipes-containers/cri-o/cri-o_git.bb DEPENDS on or otherwise requires it).
48 # ERROR: Required build target 'meta-world-pkgdata' has no buildable providers.
49 # Missing or unbuildable dependency chain was: ['meta-world-pkgdata', 'cri-o', 'libseccomp']
50 if 'security' not in d.getVar('BBFILE_COLLECTIONS').split():
51 msg += "Make sure meta-security should be present as it provides 'libseccomp'"
52 raise bb.parse.SkipRecipe(msg)
53 # ERROR: Nothing PROVIDES 'ostree' (but /buildarea/layers/meta-virtualization/recipes-containers/cri-o/cri-o_git.bb DEPENDS on or otherwise requires it).
54 # ERROR: Required build target 'meta-world-pkgdata' has no buildable providers.
55 # Missing or unbuildable dependency chain was: ['meta-world-pkgdata', 'cri-o', 'ostree']
56 elif 'cube' not in d.getVar('BBFILE_COLLECTIONS').split():
57 msg += "Make sure meta-cube should be present as it provides 'ostree'"
58 raise bb.parse.SkipRecipe(msg)
59 # ERROR: Nothing PROVIDES 'libselinux' (but /buildarea/layers/meta-virtualization/recipes-containers/cri-o/cri-o_git.bb DEPENDS on or otherwise requires it).
60 # ERROR: Required build target 'meta-world-pkgdata' has no buildable providers.
61 # Missing or unbuildable dependency chain was: ['meta-world-pkgdata', 'cri-o', 'libselinux']
62 elif 'selinux' not in d.getVar('BBFILE_COLLECTIONS').split():
63 msg += "Make sure meta-selinux should be present as it provides 'libselinux'"
64 raise bb.parse.SkipRecipe(msg)
65}
66
45PACKAGES =+ "${PN}-config" 67PACKAGES =+ "${PN}-config"
46 68
47RDEPENDS_${PN} += " virtual/containerd virtual/runc" 69RDEPENDS_${PN} += " virtual/containerd virtual/runc"