summaryrefslogtreecommitdiffstats
path: root/recipes-containers/cri-o/cri-o_git.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2023-02-17 07:28:11 -0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2023-02-17 15:34:51 -0500
commit253cf1d57239bf7e8cdea7797ddcc5e9e87c8e85 (patch)
treedfc15fd55e1f1c60b0889a1dd1165cb765304d88 /recipes-containers/cri-o/cri-o_git.bb
parent08fb12bbcce5530e0030e756cffb2e34f1ee4930 (diff)
downloadmeta-virtualization-253cf1d57239bf7e8cdea7797ddcc5e9e87c8e85.tar.gz
cri-o: use PACKAGECONFIG to handle selinux
For cri-o, libselinux is optional, this can be seen from its Makefile. So let's make selinux optional by using PACKAGECONFIG, whose default value is determined by the DISTRO_FEATURES. In this way, meta-selinux dependency is not necessary. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/cri-o/cri-o_git.bb')
-rw-r--r--recipes-containers/cri-o/cri-o_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-containers/cri-o/cri-o_git.bb b/recipes-containers/cri-o/cri-o_git.bb
index 1106cd56..5895274a 100644
--- a/recipes-containers/cri-o/cri-o_git.bb
+++ b/recipes-containers/cri-o/cri-o_git.bb
@@ -39,14 +39,14 @@ DEPENDS = " \
39 ostree \ 39 ostree \
40 libdevmapper \ 40 libdevmapper \
41 libseccomp \ 41 libseccomp \
42 libselinux \
43 " 42 "
44RDEPENDS:${PN} = " \ 43RDEPENDS:${PN} = " \
45 cni \ 44 cni \
46 libdevmapper \ 45 libdevmapper \
47 " 46 "
48 47
49SKIP_RECIPE[cri-o] ?= "${@bb.utils.contains('BBFILE_COLLECTIONS', 'selinux', '', 'Depends on libselinux from meta-selinux which is not included', d)}" 48PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'selinux', d)}"
49PACKAGECONFIG[selinux] = ",,libselinux"
50 50
51PACKAGES =+ "${PN}-config" 51PACKAGES =+ "${PN}-config"
52 52