summaryrefslogtreecommitdiffstats
path: root/recipes-containers/cri-o/cri-o_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-04-03 21:51:31 +0200
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-04-06 20:34:26 -0400
commit04f8621d8213630e3072321c68089ac147e21ebe (patch)
tree0478365a34ae96ab61584583653f7689aaf4dab9 /recipes-containers/cri-o/cri-o_git.bb
parent4c073402756248acd32b209b7b8a5e1fe328b13b (diff)
downloadmeta-virtualization-04f8621d8213630e3072321c68089ac147e21ebe.tar.gz
cri-o, podman, packagegroup-container: replace anonymous python function calling bb.parse.SkipRecipe with conditional PNBLACKLISTs
* PNBLACKLISTs are IMHO a bit easier to read and easier to override from distro which e.g. provides own recipe for libseccomp Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/cri-o/cri-o_git.bb')
-rw-r--r--recipes-containers/cri-o/cri-o_git.bb16
1 files changed, 1 insertions, 15 deletions
diff --git a/recipes-containers/cri-o/cri-o_git.bb b/recipes-containers/cri-o/cri-o_git.bb
index 2d6187a8..0ac5ddc5 100644
--- a/recipes-containers/cri-o/cri-o_git.bb
+++ b/recipes-containers/cri-o/cri-o_git.bb
@@ -43,21 +43,7 @@ RDEPENDS_${PN} = " \
43 libdevmapper \ 43 libdevmapper \
44 " 44 "
45 45
46python __anonymous() { 46PNBLACKLIST[cri-o] ?= "${@bb.utils.contains('BBFILE_COLLECTIONS', 'security', bb.utils.contains('BBFILE_COLLECTIONS', 'selinux', '', 'Depends on libselinux from meta-selinux which is not included', d), 'Depends on libseccomp from meta-security which is not included', d)}"
47 msg = ""
48 # ERROR: Nothing PROVIDES 'libseccomp' (but /buildarea/layers/meta-virtualization/recipes-containers/cri-o/cri-o_git.bb DEPENDS on or otherwise requires it).
49 # ERROR: Required build target 'meta-world-pkgdata' has no buildable providers.
50 # Missing or unbuildable dependency chain was: ['meta-world-pkgdata', 'cri-o', 'libseccomp']
51 if 'security' not in d.getVar('BBFILE_COLLECTIONS').split():
52 msg += "Make sure meta-security should be present as it provides 'libseccomp'"
53 raise bb.parse.SkipRecipe(msg)
54 # ERROR: Nothing PROVIDES 'libselinux' (but /buildarea/layers/meta-virtualization/recipes-containers/cri-o/cri-o_git.bb DEPENDS on or otherwise requires it).
55 # ERROR: Required build target 'meta-world-pkgdata' has no buildable providers.
56 # Missing or unbuildable dependency chain was: ['meta-world-pkgdata', 'cri-o', 'libselinux']
57 elif 'selinux' not in d.getVar('BBFILE_COLLECTIONS').split():
58 msg += "Make sure meta-selinux should be present as it provides 'libselinux'"
59 raise bb.parse.SkipRecipe(msg)
60}
61 47
62PACKAGES =+ "${PN}-config" 48PACKAGES =+ "${PN}-config"
63 49