summaryrefslogtreecommitdiffstats
path: root/recipes-containers/buildah
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2023-04-01 14:15:13 +0200
committerBruce Ashfield <bruce.ashfield@gmail.com>2023-04-12 13:10:11 -0400
commitf964138a214566945a7e902ca2b063ed5c4eec7b (patch)
tree8b4b7e739a032082129ebbf7923f6e9fc7da2b59 /recipes-containers/buildah
parenteacc1c3128bb2d387699ef4ad19ec4b3f4044d7d (diff)
downloadmeta-virtualization-f964138a214566945a7e902ca2b063ed5c4eec7b.tar.gz
buildah: add seccomp and ipv6 to REQUIRED_DISTRO_FEATURES
* because it rdepends on podman with the same restriction * BTW: .gitignore has: build*/ which gets triggered for buildah as well: meta-virtualization $ git add ./recipes-containers/buildah/buildah_git.bb The following paths are ignored by one of your .gitignore files: recipes-containers/buildah I've adjusted it to /build*/ only. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/buildah')
-rw-r--r--recipes-containers/buildah/buildah_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-containers/buildah/buildah_git.bb b/recipes-containers/buildah/buildah_git.bb
index 3c17c98c..8c6b8f3b 100644
--- a/recipes-containers/buildah/buildah_git.bb
+++ b/recipes-containers/buildah/buildah_git.bb
@@ -16,6 +16,10 @@ inherit go
16inherit goarch 16inherit goarch
17inherit pkgconfig 17inherit pkgconfig
18 18
19# Rdepends on podman which needs seccomp and ipv6
20inherit features_check
21REQUIRED_DISTRO_FEATURES = "seccomp ipv6"
22
19GO_IMPORT = "github.com/containers/buildah" 23GO_IMPORT = "github.com/containers/buildah"
20GO_INSTALL = "${GO_IMPORT}" 24GO_INSTALL = "${GO_IMPORT}"
21GO_WORKDIR = "${GO_INSTALL}" 25GO_WORKDIR = "${GO_INSTALL}"