summaryrefslogtreecommitdiffstats
path: root/recipes-containers/buildah
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2023-11-09 06:22:33 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2023-11-09 06:25:16 +0000
commita215d8320edee0a317a6511e7e2efa5bba867486 (patch)
tree56efb52e5d31003dbf562f44094d66e14bb78249 /recipes-containers/buildah
parent5587dd15356f9897e9e000da4ba6e08733d24287 (diff)
downloadmeta-virtualization-a215d8320edee0a317a6511e7e2efa5bba867486.tar.gz
buildah: drop statically linked x86 entrypoint
commit e89fac6c9bf8d0b [Add `buildah mkcw`, add `--cw` to `buildah commit` and `buildah build`] added a statically linked x86 entrypoint binary This entrypoint is not currently used in the tested / supported worflows. To avoid packaging QA warnings on non-x86 architectures, we remove the binary during the compilation phase. If it does need to be rebuilt in the future, buildah's Makefiles will have to be changed to not test the host for architecture support, and use the OE defined target arch and cross compilers instead. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/buildah')
-rw-r--r--recipes-containers/buildah/buildah_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-containers/buildah/buildah_git.bb b/recipes-containers/buildah/buildah_git.bb
index e29e72ff..0819bfe9 100644
--- a/recipes-containers/buildah/buildah_git.bb
+++ b/recipes-containers/buildah/buildah_git.bb
@@ -45,11 +45,15 @@ do_compile:prepend() {
45 45
46go_do_compile() { 46go_do_compile() {
47 export TMPDIR="${GOTMPDIR}" 47 export TMPDIR="${GOTMPDIR}"
48 export AS='${CC} -c'
48 if [ -n "${GO_INSTALL}" ]; then 49 if [ -n "${GO_INSTALL}" ]; then
49 ${GO} install ${GOBUILDFLAGS} ./cmd/buildah 50 ${GO} install ${GOBUILDFLAGS} ./cmd/buildah
50 ${GO} install ${GOBUILDFLAGS} ./tests/imgtype/imgtype.go 51 ${GO} install ${GOBUILDFLAGS} ./tests/imgtype/imgtype.go
51 ${GO} install ${GOBUILDFLAGS} ./tests/copy/copy.go 52 ${GO} install ${GOBUILDFLAGS} ./tests/copy/copy.go
52 fi 53 fi
54
55 # x86 statically linked executable that we don't need
56 rm -f ${S}/src/github.com/containers/buildah/internal/mkcw/embed/entrypoint
53} 57}
54 58
55do_install:append() { 59do_install:append() {