summaryrefslogtreecommitdiffstats
path: root/conf
diff options
context:
space:
mode:
authorChristopher Clark <christopher.w.clark@gmail.com>2020-06-29 18:54:49 -0700
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-07-06 16:25:56 -0400
commit90a01fcbd93d2efc94ca5d296e6a5d45fa9778ec (patch)
treead8428f4f0ad629255fbe5d615a19e049e5275a5 /conf
parent4c0e161157be1111c03367da82f690ec7cf6c9e2 (diff)
downloadmeta-virtualization-90a01fcbd93d2efc94ca5d296e6a5d45fa9778ec.tar.gz
xen, raspberry pi: add dynamic-layer for Xen configuration for Rpi4
A Xen-specific u-boot script is needed for launching Xen, and the GIC (interrupt controller) needs to be enabled. Since this is both Xen-specific and Raspberry Pi-specific, use a dynamic layer to conditionally enable the recipes when both meta-virtualization and meta-raspberrypi are in use together. Signed-off-by: Christopher Clark <christopher.w.clark@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'conf')
-rw-r--r--conf/layer.conf15
1 files changed, 15 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 142621c3..1ec7a157 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -11,6 +11,21 @@ BBFILE_PRIORITY_virtualization-layer = "8"
11# Custom licenses used by some packages in this layer 11# Custom licenses used by some packages in this layer
12LICENSE_PATH += "${LAYERDIR}/files/custom-licenses" 12LICENSE_PATH += "${LAYERDIR}/files/custom-licenses"
13 13
14# The dynamic-layers directory hosts extensions and layer-specific
15# modifications.
16#
17# The .bbappend and .bb files are included if the respective layer
18# collection is available.
19BBFILES += "${@' '.join('${LAYERDIR}/dynamic-layers/%s/recipes*/*/*.bbappend' % layer \
20 for layer in BBFILE_COLLECTIONS.split())}"
21BBFILES += "${@' '.join('${LAYERDIR}/dynamic-layers/%s/recipes*/*/*.bb' % layer \
22 for layer in BBFILE_COLLECTIONS.split())}"
23
24BBFILES_DYNAMIC += " \
25 raspberrypi:${LAYERDIR}/dynamic-layers/raspberrypi/*/*/*.bb \
26 raspberrypi:${LAYERDIR}/dynamic-layers/rasbperrypi/*/*/*.bbappend \
27"
28
14# This should only be incremented on significant changes that will 29# This should only be incremented on significant changes that will
15# cause compatibility issues with other layers 30# cause compatibility issues with other layers
16LAYERVERSION_virtualization-layer = "1" 31LAYERVERSION_virtualization-layer = "1"