summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLavocat, Nicolas <Nicolas.Lavocat@harman.com>2020-08-06 10:38:59 +0200
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-08-07 22:20:03 -0400
commitff997b6b3ba800978546098ab3cdaa113b6695e1 (patch)
tree98e3267ce244149192b618e3348131bed99fb7c1
parentffd787fb850e5a1657a01febc8402c74832147a1 (diff)
downloadmeta-virtualization-ff997b6b3ba800978546098ab3cdaa113b6695e1.tar.gz
libvirt: fix install error without qemu
An error occurs during the install step of libvirt when the variable PACKAGECONFIG does not contain qemu. Indeed, in this case, the operation "chown -R qemu:qemu ${D}/${localstatedir}/lib/libvirt/qemu" fails, since the folder ${D}/${localstatedir}/lib/libvirt/qemu has not been created. The fix consist in doing this operation only if the variable “PACKAGECONFIG” contains “qemu”. remark: issue present since the Warrior release of yocto. Upstream-Status: Pending Signed-off-by: Nicolas Lavocat <nicolas.lavocat@harman.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-extended/libvirt/libvirt_6.1.0.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/recipes-extended/libvirt/libvirt_6.1.0.bb b/recipes-extended/libvirt/libvirt_6.1.0.bb
index 9aa78b77..f301a0e3 100644
--- a/recipes-extended/libvirt/libvirt_6.1.0.bb
+++ b/recipes-extended/libvirt/libvirt_6.1.0.bb
@@ -340,10 +340,12 @@ do_install_append() {
340 break 340 break
341 ;; 341 ;;
342 *) 342 *)
343 chown -R qemu:qemu ${D}/${localstatedir}/lib/libvirt/qemu 343 if ${@bb.utils.contains('PACKAGECONFIG', 'qemu', 'true', 'false', d)}; then
344 echo "d qemu qemu 0755 ${localstatedir}/cache/libvirt/qemu none" \ 344 chown -R qemu:qemu ${D}/${localstatedir}/lib/libvirt/qemu
345 >> ${D}${sysconfdir}/default/volatiles/99_libvirt 345 echo "d qemu qemu 0755 ${localstatedir}/cache/libvirt/qemu none" \
346 break 346 >> ${D}${sysconfdir}/default/volatiles/99_libvirt
347 break
348 fi
347 ;; 349 ;;
348 esac 350 esac
349 351