summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-12-19 23:02:35 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-12-28 11:11:37 -0500
commitf65d364dfff5a554cf0842aee227808bb9b97c9b (patch)
tree94dec406dc41d8f5458c180969330321222b66f8
parent4fa904e57f7fb730195d13c49fe3d1c2b43544bc (diff)
downloadmeta-virtualization-f65d364dfff5a554cf0842aee227808bb9b97c9b.tar.gz
python3-websocket-client: make py2 version available
Allow a py2 version of the python-websocket-client package to be built. This is required to support updates in meta-cloud-services. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-devtools/python/python-websocket-client.inc11
-rw-r--r--recipes-devtools/python/python-websocket-client_0.44.0.bb2
-rw-r--r--recipes-devtools/python/python3-websocket-client_0.44.0.bb13
3 files changed, 15 insertions, 11 deletions
diff --git a/recipes-devtools/python/python-websocket-client.inc b/recipes-devtools/python/python-websocket-client.inc
new file mode 100644
index 00000000..31778c68
--- /dev/null
+++ b/recipes-devtools/python/python-websocket-client.inc
@@ -0,0 +1,11 @@
1SUMMARY = "WebSocket client for python. hybi13 is supported."
2HOMEPAGE = "https://github.com/websocket-client/websocket-client.git"
3LICENSE = "LGPL-3.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=18b09a20dd186af4fd60f1a08311628c"
5
6inherit pypi
7
8PYPI_PACKAGE = "websocket_client"
9
10SRC_URI[md5sum] = "73d87aa16a2212da448b30aca9c5bf3b"
11SRC_URI[sha256sum] = "15f585566e2ea7459136a632b9785aa081093064391878a448c382415e948d72"
diff --git a/recipes-devtools/python/python-websocket-client_0.44.0.bb b/recipes-devtools/python/python-websocket-client_0.44.0.bb
new file mode 100644
index 00000000..11eeb04a
--- /dev/null
+++ b/recipes-devtools/python/python-websocket-client_0.44.0.bb
@@ -0,0 +1,2 @@
1require python-websocket-client.inc
2inherit setuptools \ No newline at end of file
diff --git a/recipes-devtools/python/python3-websocket-client_0.44.0.bb b/recipes-devtools/python/python3-websocket-client_0.44.0.bb
index 8dfc95f5..473e31ff 100644
--- a/recipes-devtools/python/python3-websocket-client_0.44.0.bb
+++ b/recipes-devtools/python/python3-websocket-client_0.44.0.bb
@@ -1,11 +1,2 @@
1SUMMARY = "WebSocket client for python. hybi13 is supported." 1require python-websocket-client.inc
2HOMEPAGE = "https://github.com/websocket-client/websocket-client.git" 2inherit setuptools3 \ No newline at end of file
3LICENSE = "LGPL-3.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=18b09a20dd186af4fd60f1a08311628c"
5
6inherit pypi setuptools3
7
8PYPI_PACKAGE = "websocket_client"
9
10SRC_URI[md5sum] = "73d87aa16a2212da448b30aca9c5bf3b"
11SRC_URI[sha256sum] = "15f585566e2ea7459136a632b9785aa081093064391878a448c382415e948d72"