summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@siemens.com>2018-05-25 15:58:20 +0200
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-05-29 10:25:41 -0400
commitf26bdea05c499ba544198afc95e7a4b344c4d3ba (patch)
tree0bf9998bfc3e1b443ddc87d66164becf831b6917
parentd273f1f4916e54dd0e89802919f5b0ae6823562b (diff)
downloadmeta-virtualization-f26bdea05c499ba544198afc95e7a4b344c4d3ba.tar.gz
docker: allow enabling seccomp
This requires libseccomp from meta-security so it is not enabled by default. Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-containers/docker/docker_git.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes-containers/docker/docker_git.bb b/recipes-containers/docker/docker_git.bb
index e055a4f6..790170e9 100644
--- a/recipes-containers/docker/docker_git.bb
+++ b/recipes-containers/docker/docker_git.bb
@@ -62,6 +62,9 @@ DEPENDS = " \
62 libtool \ 62 libtool \
63 " 63 "
64 64
65PACKAGECONFIG ??= ""
66PACKAGECONFIG[seccomp] = "seccomp,,libseccomp"
67
65PACKAGES =+ "${PN}-contrib" 68PACKAGES =+ "${PN}-contrib"
66 69
67DEPENDS_append_class-target = " lvm2" 70DEPENDS_append_class-target = " lvm2"
@@ -105,7 +108,7 @@ do_compile() {
105 export CGO_CFLAGS="${CFLAGS} --sysroot=${STAGING_DIR_TARGET}" 108 export CGO_CFLAGS="${CFLAGS} --sysroot=${STAGING_DIR_TARGET}"
106 export CGO_LDFLAGS="${LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" 109 export CGO_LDFLAGS="${LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
107 # in order to exclude devicemapper and btrfs - https://github.com/docker/docker/issues/14056 110 # in order to exclude devicemapper and btrfs - https://github.com/docker/docker/issues/14056
108 export DOCKER_BUILDTAGS='exclude_graphdriver_btrfs exclude_graphdriver_devicemapper' 111 export DOCKER_BUILDTAGS='exclude_graphdriver_btrfs exclude_graphdriver_devicemapper ${PACKAGECONFIG_CONFARGS}'
109 112
110 export DISABLE_WARN_OUTSIDE_CONTAINER=1 113 export DISABLE_WARN_OUTSIDE_CONTAINER=1
111 114