summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2018-10-10 14:59:12 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-10-11 14:38:16 -0400
commitf2446873e7b0201b1df9c710dddbfc5475e998fb (patch)
treed109f7ecd41b282b36f7d7a4cd1b325f2f4f7dbc
parent0442f2e7b85b66d791e04a06de394225f0e146b5 (diff)
downloadmeta-virtualization-f2446873e7b0201b1df9c710dddbfc5475e998fb.tar.gz
docker: fix do package qa warning
1. After security flag PIE is enabled by default, we might met below QA warning on some arch, like aarch64, fix it by skip textrel QA check refer commit b689c72a of oe-core WARNING: docker-18.03.0+git708b068d3095c6a6be939eb2da78c921d2e945e2-r0 do_package_qa: QA Issue: ELF binary 'work/aarch64-poky-linux/docker/ 18.03.0+git708b068d3095c6a6be939eb2da78c921d2e945e2-r0/packages-split/ docker/usr/bin/docker' has relocations in .text [textrel] 2. This problem is caused since security_flags.inc is used by default. so alternative work around is: SECURITY_CFLAGS_pn-docker = "${SECURITY_NOPIE_CFLAGS}" SECURITY_LDFLAGS_pn-docker = "" Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-containers/docker/docker_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-containers/docker/docker_git.bb b/recipes-containers/docker/docker_git.bb
index 73e01203..b3673d43 100644
--- a/recipes-containers/docker/docker_git.bb
+++ b/recipes-containers/docker/docker_git.bb
@@ -172,4 +172,4 @@ RDEPENDS_${PN}-contrib += "bash"
172 172
173# DO NOT STRIP docker 173# DO NOT STRIP docker
174INHIBIT_PACKAGE_STRIP = "1" 174INHIBIT_PACKAGE_STRIP = "1"
175INSANE_SKIP_${PN} += "ldflags" 175INSANE_SKIP_${PN} += "ldflags textrel"