summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Clark <christopher.w.clark@gmail.com>2018-08-18 18:37:15 -0700
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-08-20 11:35:53 -0400
commiteb1bb802c91cd3fe4d8cd7f4511119122dd4555d (patch)
tree14b23115ae0ce8ae1ee885e249a3f8b1b8f2160d
parent3266a8814259da66244b0381933ae188fcae41de (diff)
downloadmeta-virtualization-eb1bb802c91cd3fe4d8cd7f4511119122dd4555d.tar.gz
xen: enable 32-bit ARM builds
Enable recipe for COMPATIBLE_HOST = 'arm-.*-linux-gnueabi' Tested with a cubietruck, upstream's reference device for this class. Signed-off-by: Christopher Clark <christopher.clark6@baesystems.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-extended/xen/xen.inc7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes-extended/xen/xen.inc b/recipes-extended/xen/xen.inc
index 38cecd1d..bf4b3c28 100644
--- a/recipes-extended/xen/xen.inc
+++ b/recipes-extended/xen/xen.inc
@@ -5,7 +5,7 @@ SECTION = "console/tools"
5 5
6LIC_FILES_CHKSUM = "file://COPYING;md5=bbb4b1bdc2c3b6743da3c39d03249095" 6LIC_FILES_CHKSUM = "file://COPYING;md5=bbb4b1bdc2c3b6743da3c39d03249095"
7 7
8COMPATIBLE_HOST = '(x86_64.*).*-linux|aarch64.*-linux' 8COMPATIBLE_HOST = '(x86_64.*).*-linux|aarch64.*-linux|arm-.*-linux-gnueabi'
9 9
10inherit autotools-brokensep setuptools update-rc.d systemd deploy 10inherit autotools-brokensep setuptools update-rc.d systemd deploy
11 11
@@ -918,6 +918,11 @@ do_post_patch() {
918 fi 918 fi
919} 919}
920 920
921do_post_patch_append_arm() {
922 # The hypervisor binary must not be built with the hard floating point ABI.
923 echo "CC := \$(filter-out ${TUNE_CCARGS},\$(CC))" >> ${B}/xen/arch/arm/Rules.mk
924}
925
921addtask post_patch after do_patch before do_configure 926addtask post_patch after do_patch before do_configure
922 927
923do_stubs() { 928do_stubs() {