summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongzhi.Song <hongzhi.song@windriver.com>2018-07-24 03:12:28 -0700
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-07-26 10:40:26 -0400
commite2ab59ec3e4b547da635cda725090d42126dcfd2 (patch)
tree08845ab09d5c5979d6c67bff7d73db0f77c4b08c
parent17613c1a3bac1c60c57dbfa43558d3f64762a027 (diff)
downloadmeta-virtualization-e2ab59ec3e4b547da635cda725090d42126dcfd2.tar.gz
libvmi: add a new recipe
LibVMI is a C library with Python bindings that makes it easy to monitor the low-level details of a running virtual machine by viewing its memory, trapping on hardware events, and accessing the vCPU registers. This is called virtual machine introspection. Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-extended/libvmi/libvmi_git.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-extended/libvmi/libvmi_git.bb b/recipes-extended/libvmi/libvmi_git.bb
new file mode 100644
index 00000000..a746638f
--- /dev/null
+++ b/recipes-extended/libvmi/libvmi_git.bb
@@ -0,0 +1,41 @@
1DESCRIPTION = "An introspection library, written in C, focused on reading \
2 and writing memory from virtual machines (VM's)."
3HOMEPAGE = "https://github.com/libvmi/libvmi"
4LICENSE = "LGPLv3"
5LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=e6a600fd5e1d9cbde2d983680233ad02"
6SECTION = "console/tools"
7PV = "0.12.0"
8
9DEPENDS = "libvirt libcheck bison fuse"
10
11SRC_URI = "git://github.com/libvmi/libvmi.git \
12"
13
14SRCREV = "6934e8a4758018983ec53ec791dd14a7d6ac31a9"
15
16S = "${WORKDIR}/git"
17
18inherit autotools-brokensep pkgconfig
19
20# Noramlly dynamic libs would be of the form libXX.so.1.0.0 in which case
21# bitbake should be able to properly populate the -dev package and the main
22# packages. Since libvmi uses the form libXX.1.0.0.so it breaks this automatic
23# packaging so we need to be more explicit about what goes where.
24FILES_${PN} += "${libdir}/libvmi-0.9.so"
25FILES_${PN}-dev = "${includedir} ${libdir}/${BPN}.so ${libdir}/*.la \
26 ${libdir}/*.o ${libdir}/pkgconfig ${datadir}/pkgconfig \
27 ${datadir}/aclocal ${base_libdir}/*.o \
28 ${libdir}/${BPN}/*.la ${base_libdir}/*.la"
29
30PACKAGECONFIG ??= "json-c"
31PACKAGECONFIG[xen] = "--enable-xen,--disable-xen,xen,"
32PACKAGECONFIG[json-c] = ",,json-c,"
33
34# We include a sample conf file to which we have added
35do_install_append () {
36 mkdir ${D}${sysconfdir}
37 cp etc/*.conf ${D}${sysconfdir}
38}
39
40# Construction of grammar.h is not parallel safe.
41PARALLEL_MAKE = "-j1"