summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2023-10-26 19:43:49 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2023-11-06 16:21:12 +0000
commitd1d50f9861786ec21d0a0dcc1028dfc3c310300f (patch)
tree89e1b9ccff030f19ef7fdcc12fa2ba48d914d9a3
parente26e7806743a32a14f87f04a3bcb747293413ccc (diff)
downloadmeta-virtualization-d1d50f9861786ec21d0a0dcc1028dfc3c310300f.tar.gz
cni: clean dir ${B}/plugins before do_compile
Clean dir ${B}/plugins before do_compile to avoid cni generated binaries like /usr/libexec/cni/bridge has wrong dynamic linker path and reports error like: /usr/libexec/cni/bridge: no such file or directory". Reproduce steps: 1. bitbake cni 2. enable usrmerge feature in local.conf 3. bitbake cni After step 2, GOBUILDFLAGS changed, "-I /lib64/ld-linux-aarch64.so.1" -> "/usr/lib/ld-linux-aarch64.so.1" But "go build" seems only check if the cached packagefile changed, since all not changed, the dynamic linker still use the old one, maybe go build should improve this. Clean dir ${B}/plugins to trigger rebuild of the binaries here. Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-networking/cni/cni_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-networking/cni/cni_git.bb b/recipes-networking/cni/cni_git.bb
index 71880cd1..a1a31f2d 100644
--- a/recipes-networking/cni/cni_git.bb
+++ b/recipes-networking/cni/cni_git.bb
@@ -53,6 +53,8 @@ do_compile() {
53 done 53 done
54} 54}
55 55
56do_compile[cleandirs] = "${B}/plugins"
57
56do_install() { 58do_install() {
57 localbindir="${libexecdir}/cni/" 59 localbindir="${libexecdir}/cni/"
58 60