summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDengke Du <dengke.du@windriver.com>2018-11-08 13:18:37 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-11-08 14:53:15 -0500
commitccdf4ef7b82ea2012c0ed75506c2f2adc5b384d4 (patch)
treeca46b3e17a8bd4393053a03074786ea0cca40c3f
parentd9c64d8aa0d7c5ca8d55e1443684c243b01186f0 (diff)
downloadmeta-virtualization-ccdf4ef7b82ea2012c0ed75506c2f2adc5b384d4.tar.gz
ceph: fix rbd create operation not supported
When using qemu-img to create rbd based image: qemu-img create -f rbd rbd:libvirt-pool/libvirt-image 2G Output errors: qemu-img: rbd:libvirt-pool/libvirt-image: error rbd create: Operation not supported Accroding to upstream's advice: http://lists.ceph.com/pipermail/ceph-users-ceph.com/2018-November/031014.html This is because the system can't find libcls_rbd.so, this library was packaged in ceph-dev, we should package it in ceph. Signed-off-by: Dengke Du <dengke.du@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-extended/ceph/ceph_13.2.2.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/recipes-extended/ceph/ceph_13.2.2.bb b/recipes-extended/ceph/ceph_13.2.2.bb
index 3d9faae3..08021cf7 100644
--- a/recipes-extended/ceph/ceph_13.2.2.bb
+++ b/recipes-extended/ceph/ceph_13.2.2.bb
@@ -80,9 +80,7 @@ do_install_append () {
80} 80}
81 81
82FILES_${PN} += "\ 82FILES_${PN} += "\
83 ${libdir}/rados-classes/*.so.* \ 83 ${libdir}/rados-classes/*.so.* \
84"
85FILES_${PN}-dev += "\
86 ${libdir}/ceph/compressor/*.so \ 84 ${libdir}/ceph/compressor/*.so \
87 ${libdir}/rados-classes/*.so \ 85 ${libdir}/rados-classes/*.so \
88 ${libdir}/ceph/*.so \ 86 ${libdir}/ceph/*.so \
@@ -102,3 +100,4 @@ PACKAGES += " \
102 ${PN}-python \ 100 ${PN}-python \
103" 101"
104INSANE_SKIP_${PN}-python += "ldflags" 102INSANE_SKIP_${PN}-python += "ldflags"
103INSANE_SKIP_${PN} += "dev-so"