summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Clark <christopher.w.clark@gmail.com>2018-07-31 12:35:45 -0700
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-08-02 22:57:14 -0400
commitc5d44796981afb32cad6c685cde6d6175423c4d7 (patch)
treeeb9bb8e717e51452083082bdbd713f04bd2716ac
parentf9650d8997505796883d0ef61bd8ad2a87c2b36e (diff)
downloadmeta-virtualization-c5d44796981afb32cad6c685cde6d6175423c4d7.tar.gz
xen-vtpm,mini-os : upgrade to Xen 4.11.0
drops the gcc7 compatibility patch -- no longer required as it is present in the upstream version. Signed-off-by: Christopher Clark <christopher.clark6@baesystems.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-extended/xen/files/mini-os_udivmoddi4-gcc7.patch43
-rw-r--r--recipes-extended/xen/mini-os_4.11.0.bb (renamed from recipes-extended/xen/mini-os_4.9.0.bb)5
-rw-r--r--recipes-extended/xen/xen-vtpm_4.11.0.bb (renamed from recipes-extended/xen/xen-vtpm_4.9.0.bb)4
3 files changed, 4 insertions, 48 deletions
diff --git a/recipes-extended/xen/files/mini-os_udivmoddi4-gcc7.patch b/recipes-extended/xen/files/mini-os_udivmoddi4-gcc7.patch
deleted file mode 100644
index a3745bda..00000000
--- a/recipes-extended/xen/files/mini-os_udivmoddi4-gcc7.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1From d991bdbc062248221511ecb795617c36b37e1d2e Mon Sep 17 00:00:00 2001
2From: Wei Liu <wei.liu2@citrix.com>
3Date: Wed, 9 Aug 2017 13:15:48 +0100
4Subject: [PATCH] lib/math.c: implement __udivmoddi4
5
6Some code compiled by gcc 7 requires this.
7
8Signed-off-by: Wei Liu <wei.liu2@citrix.com>
9Reviewed-by: Samuel Thibault <samuel.thibault@ens-lyon.org>
10---
11 lib/math.c | 10 ++++++++++
12 1 file changed, 10 insertions(+)
13
14diff --git a/lib/math.c b/lib/math.c
15index 561393e..b98cc1d 100644
16--- a/lib/math.c
17+++ b/lib/math.c
18@@ -6,6 +6,7 @@
19 * File: math.c
20 * Author: Rolf Neugebauer (neugebar@dcs.gla.ac.uk)
21 * Changes:
22+ * Implement __udivmoddi4 (Wei Liu <wei.liu2@citrix.com>)
23 *
24 * Date: Aug 2003
25 *
26@@ -397,6 +398,15 @@ __umoddi3(u_quad_t a, u_quad_t b)
27 }
28
29 /*
30+ * Returns the quotient and places remainder in r
31+ */
32+u_quad_t
33+__udivmoddi4(u_quad_t a, u_quad_t b, u_quad_t *r)
34+{
35+ return __qdivrem(a, b, r);
36+}
37+
38+/*
39 * From
40 * moddi3.c
41 */
42--
432.11.0
diff --git a/recipes-extended/xen/mini-os_4.9.0.bb b/recipes-extended/xen/mini-os_4.11.0.bb
index 298bc8df..85a06a79 100644
--- a/recipes-extended/xen/mini-os_4.9.0.bb
+++ b/recipes-extended/xen/mini-os_4.11.0.bb
@@ -6,11 +6,10 @@ HOMEPAGE = "https://wiki.xenproject.org/wiki/Mini-OS"
6LICENSE = "GPLv2" 6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=8a437231894440a8f7629caa372243d0" 7LIC_FILES_CHKSUM = "file://COPYING;md5=8a437231894440a8f7629caa372243d0"
8 8
9# git commit hash for tags: xen-RELEASE-4.9.0, xen-RELEASE-4.9.1, xen-RELEASE-4.9.2 9# git commit hash for: xen-RELEASE-4.11.0
10SRCREV_minios = "ca013fa9baf92f47469ba1f2e1aaa31c41d8a0bb" 10SRCREV_minios = "0b4b7897e08b967a09bed2028a79fabff82342dd"
11SRC_URI = "\ 11SRC_URI = "\
12 git://xenbits.xen.org/mini-os.git;protocol=git;nobranch=1;destsuffix=mini-os;name=minios \ 12 git://xenbits.xen.org/mini-os.git;protocol=git;nobranch=1;destsuffix=mini-os;name=minios \
13 file://mini-os_udivmoddi4-gcc7.patch \
14" 13"
15S="${WORKDIR}/mini-os" 14S="${WORKDIR}/mini-os"
16B="${S}" 15B="${S}"
diff --git a/recipes-extended/xen/xen-vtpm_4.9.0.bb b/recipes-extended/xen/xen-vtpm_4.11.0.bb
index c58a02d8..088e985b 100644
--- a/recipes-extended/xen/xen-vtpm_4.9.0.bb
+++ b/recipes-extended/xen/xen-vtpm_4.11.0.bb
@@ -8,8 +8,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b1ceb1b03a49b202ee6f41ffd1ed0155 \
8 file://vtpm/COPYING;md5=75a98062ab0322ded060d9026a1bda61 \ 8 file://vtpm/COPYING;md5=75a98062ab0322ded060d9026a1bda61 \
9" 9"
10 10
11# git commit hash for Xen's RELEASE-4.9.0 tag 11# git commit hash for Xen's RELEASE-4.11.0 tag
12SRCREV_xen = "c30bf55594a53fae8aae08aabf16fc192faad7da" 12SRCREV_xen = "1eb6544a567e3e5133fafe0c4ef3545c5138d0e4"
13SRC_URI = "\ 13SRC_URI = "\
14 git://xenbits.xen.org/xen.git;protocol=git;nobranch=1;name=xen;subpath=stubdom \ 14 git://xenbits.xen.org/xen.git;protocol=git;nobranch=1;name=xen;subpath=stubdom \
15 git://xenbits.xen.org/xen.git;protocol=git;nobranch=1;name=xen;destsuffix=stubdom/include;subpath=tools/xenstore/include \ 15 git://xenbits.xen.org/xen.git;protocol=git;nobranch=1;name=xen;destsuffix=stubdom/include;subpath=tools/xenstore/include \