summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Barker <pbarker@toganlabs.com>2017-10-12 16:49:56 +0000
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-10-12 21:59:51 -0400
commitc1cd2d4c69f61e1e3bd9eb8d1a85e82df454588f (patch)
tree7ed63aa215802d709b9f05521bcadd912d6556cf
parent638ba96208d28e7f7dc3c23efea2e017ea0b7a28 (diff)
downloadmeta-virtualization-c1cd2d4c69f61e1e3bd9eb8d1a85e82df454588f.tar.gz
runc-docker: Disable building recvtty
The recvtty demo/reference application has cross compilation issues when targeting aarch64 platforms. As it is just a demo application and is not usually used, we can just patch the Makefile to disable building this application. Signed-off-by: Paul Barker <pbarker@toganlabs.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-containers/runc/runc-docker/0001-Disable-building-recvtty.patch26
-rw-r--r--recipes-containers/runc/runc-docker_git.bb1
2 files changed, 27 insertions, 0 deletions
diff --git a/recipes-containers/runc/runc-docker/0001-Disable-building-recvtty.patch b/recipes-containers/runc/runc-docker/0001-Disable-building-recvtty.patch
new file mode 100644
index 00000000..fa1f695b
--- /dev/null
+++ b/recipes-containers/runc/runc-docker/0001-Disable-building-recvtty.patch
@@ -0,0 +1,26 @@
1From aa2fc7b0eacba61175f083cc8d8adc233bcd0575 Mon Sep 17 00:00:00 2001
2From: Paul Barker <pbarker@toganlabs.com>
3Date: Thu, 12 Oct 2017 11:34:24 +0000
4Subject: [PATCH] Disable building recvtty
5
6Signed-off-by: Paul Barker <pbarker@toganlabs.com>
7Upstream-status: Inappropriate
8---
9 Makefile | 1 -
10 1 file changed, 1 deletion(-)
11
12diff --git a/Makefile b/Makefile
13index 0fcf508..24f47dc 100644
14--- a/src/import/Makefile
15+++ b/src/import/Makefile
16@@ -38,7 +38,6 @@ contrib/cmd/recvtty/recvtty: $(SOURCES)
17
18 static: $(SOURCES)
19 CGO_ENABLED=1 $(GO) build -i $(EXTRA_FLAGS) -tags "$(BUILDTAGS) cgo static_build" -ldflags "-w -extldflags -static -X main.gitCommit=${COMMIT} -X main.version=${VERSION} $(EXTRA_LDFLAGS)" -o runc .
20- CGO_ENABLED=1 $(GO) build -i $(EXTRA_FLAGS) -tags "$(BUILDTAGS) cgo static_build" -ldflags "-w -extldflags -static -X main.gitCommit=${COMMIT} -X main.version=${VERSION} $(EXTRA_LDFLAGS)" -o contrib/cmd/recvtty/recvtty ./contrib/cmd/recvtty
21
22 release:
23 @flag_list=(seccomp selinux apparmor static); \
24--
252.7.4
26
diff --git a/recipes-containers/runc/runc-docker_git.bb b/recipes-containers/runc/runc-docker_git.bb
index 01986528..28232d9f 100644
--- a/recipes-containers/runc/runc-docker_git.bb
+++ b/recipes-containers/runc/runc-docker_git.bb
@@ -9,6 +9,7 @@ SRC_URI = "git://github.com/docker/runc.git;nobranch=1;name=runc-docker \
9 file://0003-Update-memory-specs-to-use-int64-not-uint64.patch \ 9 file://0003-Update-memory-specs-to-use-int64-not-uint64.patch \
10 file://0001-runc-Add-console-socket-dev-null.patch \ 10 file://0001-runc-Add-console-socket-dev-null.patch \
11 file://0001-Use-correct-go-cross-compiler.patch \ 11 file://0001-Use-correct-go-cross-compiler.patch \
12 file://0001-Disable-building-recvtty.patch \
12 " 13 "
13 14
14GO_IMPORT = "import" 15GO_IMPORT = "import"