summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@cardoe.com>2016-01-22 22:57:47 -0600
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-12-18 22:47:44 -0500
commitc0d11eeb261f65e6e3615cd9e08872c88425526d (patch)
treea520fd870b56dff95dbc3e1359e892eb7325fac2
parentc613f19bf2c5ccbcfa8dac0c9f3994d11f8f75ff (diff)
downloadmeta-virtualization-c0d11eeb261f65e6e3615cd9e08872c88425526d.tar.gz
xen-image-minimal: if DISTRO_FEATURES is missing xen error
It can be confusing to users why things are failing with missing kernel dependencies when you don't have 'xen' in your DISTRO_FEATURES. This should provide them with some better info. Signed-off-by: Doug Goldstein <cardoe@cardoe.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-extended/images/xen-image-minimal.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes-extended/images/xen-image-minimal.bb b/recipes-extended/images/xen-image-minimal.bb
index 26b6d065..b8c20022 100644
--- a/recipes-extended/images/xen-image-minimal.bb
+++ b/recipes-extended/images/xen-image-minimal.bb
@@ -20,6 +20,14 @@ LICENSE = "MIT"
20 20
21inherit core-image 21inherit core-image
22 22
23do_check_xen_state() {
24 if [ "${@bb.utils.contains('DISTRO_FEATURES', 'xen', ' yes', 'no', d)}" = "no" ]; then
25 die "DISTRO_FEATURES does not contain 'xen'"
26 fi
27}
28
29addtask check_xen_state before do_rootfs
30
23syslinux_iso_populate_append() { 31syslinux_iso_populate_append() {
24 install -m 0444 ${STAGING_DATADIR}/syslinux/libcom32.c32 ${ISODIR}${ISOLINUXDIR} 32 install -m 0444 ${STAGING_DATADIR}/syslinux/libcom32.c32 ${ISODIR}${ISOLINUXDIR}
25 install -m 0444 ${STAGING_DATADIR}/syslinux/mboot.c32 ${ISODIR}${ISOLINUXDIR} 33 install -m 0444 ${STAGING_DATADIR}/syslinux/mboot.c32 ${ISODIR}${ISOLINUXDIR}