summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-06-30 11:22:42 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-06-30 11:22:42 -0400
commitb8f2edd39af6b7ac4461158b0d0382e88e93d6f1 (patch)
tree6bceee7c5174fe4fe32308567afbbb492351546c
parentfd4b46ce228119b81725e3655ee4ba49df18a51b (diff)
downloadmeta-virtualization-b8f2edd39af6b7ac4461158b0d0382e88e93d6f1.tar.gz
crun: add seccomp distro features check
Since seccomp depends on libseccomp, and seccomp is only available when the distro feature is enabled, we add the same dependency and distro feature check to this recipe. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/crun/crun_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-containers/crun/crun_git.bb b/recipes-containers/crun/crun_git.bb
index 8c483e55..ea7faa13 100644
--- a/recipes-containers/crun/crun_git.bb
+++ b/recipes-containers/crun/crun_git.bb
@@ -24,6 +24,9 @@ inherit autotools-brokensep pkgconfig features_check
24 24
25PACKAGECONFIG ??= "" 25PACKAGECONFIG ??= ""
26 26
27inherit features_check
28REQUIRED_DISTRO_FEATURES ?= "seccomp"
29
27DEPENDS = "yajl libcap go-md2man-native m4-native" 30DEPENDS = "yajl libcap go-md2man-native m4-native"
28# TODO: is there a packageconfig to turn this off ? 31# TODO: is there a packageconfig to turn this off ?
29DEPENDS += "libseccomp" 32DEPENDS += "libseccomp"