summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2018-10-16 09:31:17 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-10-16 10:25:36 -0400
commit915c43874d8a7a759377f39c063e8484276e4dc5 (patch)
tree62327749fba9a2217fda16cd8ead5c929e4370be
parent7224fdf98a25de02000ff101aeeb1569d70a8e64 (diff)
downloadmeta-virtualization-915c43874d8a7a759377f39c063e8484276e4dc5.tar.gz
libvirt: do not defer postinstall to first boot when not necessary
The postinstall invokes `/etc/init.d/populate-volatile.sh update'. This is only useful for an on-target package upgrade. For now, this postinstall in libvirt has already got a check against $D to tell whether it's running on target or not, we do not need to use pkg_postinstall_ontarget. Otherwise, we get unnecessary postinstall deferred to first boot, which is not what we want. Note that the postinstall was originally written as 'pkg_postinstall_${PN}', but was incorrectly modified to be 'pkg_postinstall_ontarget_${PN}' by the following commit. """ commit 1e67a44db7ec87617455b3228ee5237ceb037173 Author: He Zhe <zhe.he@windriver.com> Date: Tue Jul 24 05:50:01 2018 -0700 libvirt: Remove unsupported configure options and fix warning [snip] """ I think the warning about deferred postinstall was caused by some bbappend file instead of the main recipe in this layer. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-extended/libvirt/libvirt_4.7.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-extended/libvirt/libvirt_4.7.0.bb b/recipes-extended/libvirt/libvirt_4.7.0.bb
index 47275ae6..ecccfeeb 100644
--- a/recipes-extended/libvirt/libvirt_4.7.0.bb
+++ b/recipes-extended/libvirt/libvirt_4.7.0.bb
@@ -311,7 +311,7 @@ do_install_ptest() {
311 done 311 done
312} 312}
313 313
314pkg_postinst_ontarget_${PN}() { 314pkg_postinst_${PN}() {
315 if [ -z "$D" ] && [ -e /etc/init.d/populate-volatile.sh ] ; then 315 if [ -z "$D" ] && [ -e /etc/init.d/populate-volatile.sh ] ; then
316 /etc/init.d/populate-volatile.sh update 316 /etc/init.d/populate-volatile.sh update
317 fi 317 fi