summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Quaresma <quaresma.jose@gmail.com>2022-09-30 11:46:01 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2022-10-04 16:55:18 -0400
commit8177e4a6b72d5b701b92b2028baf1a8860cf18e6 (patch)
tree7a90d5e60897ccbb4d0bd3d323747152fdcd02e9
parentde747b18ac6c028e8c8983778d87f119b0c28d14 (diff)
downloadmeta-virtualization-8177e4a6b72d5b701b92b2028baf1a8860cf18e6.tar.gz
tini: fix function declaration without a prototype
This also fix building with clang 1.15 Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/tini/tini/0001-tini.c-a-function-declaration-without-a-prototype-is.patch74
-rw-r--r--recipes-containers/tini/tini_0.19.0.bb1
2 files changed, 75 insertions, 0 deletions
diff --git a/recipes-containers/tini/tini/0001-tini.c-a-function-declaration-without-a-prototype-is.patch b/recipes-containers/tini/tini/0001-tini.c-a-function-declaration-without-a-prototype-is.patch
new file mode 100644
index 00000000..96f3625c
--- /dev/null
+++ b/recipes-containers/tini/tini/0001-tini.c-a-function-declaration-without-a-prototype-is.patch
@@ -0,0 +1,74 @@
1From 66d0b5fd94fafe1e15bf21a1b73618ca23de078f Mon Sep 17 00:00:00 2001
2From: Jose Quaresma <jose.quaresma@foundries.io>
3Date: Fri, 23 Sep 2022 16:31:33 +0000
4Subject: [PATCH] tini.c: a function declaration without a prototype is
5 deprecated in all versions of C
6
7| /srv/oe/build/tmp-lmp/work/corei7-64-lmp-linux/tini/0.19.0-r0/git/src/tini.c:150:18: error: a function declaration without a prototype is deprecated in all versions of C [-Werror,-Wstrict-prototypes]
8| int isolate_child() {
9| ^
10| void
11| /srv/oe/build/tmp-lmp/work/corei7-64-lmp-linux/tini/0.19.0-r0/git/src/tini.c:395:14: error: a function declaration without a prototype is deprecated in all versions of C [-Werror,-Wstrict-prototypes]
12| int parse_env() {
13| ^
14| void
15| /srv/oe/build/tmp-lmp/work/corei7-64-lmp-linux/tini/0.19.0-r0/git/src/tini.c:416:24: error: a function declaration without a prototype is deprecated in all versions of C [-Werror,-Wstrict-prototypes]
16| int register_subreaper () {
17| ^
18| void
19| /srv/oe/build/tmp-lmp/work/corei7-64-lmp-linux/tini/0.19.0-r0/git/src/tini.c:434:19: error: a function declaration without a prototype is deprecated in all versions of C [-Werror,-Wstrict-prototypes]
20| void reaper_check () {
21| ^
22| void
23| 4 errors generated.
24
25:Upstream-Status: Submitted [https://github.com/krallin/tini/pull/198]
26
27Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
28---
29 src/tini.c | 8 ++++----
30 1 file changed, 4 insertions(+), 4 deletions(-)
31
32diff --git a/src/tini.c b/src/tini.c
33index 2c873f9..7914d3a 100644
34--- a/src/tini.c
35+++ b/src/tini.c
36@@ -147,7 +147,7 @@ int restore_signals(const signal_configuration_t* const sigconf_ptr) {
37 return 0;
38 }
39
40-int isolate_child() {
41+int isolate_child(void) {
42 // Put the child into a new process group.
43 if (setpgid(0, 0) < 0) {
44 PRINT_FATAL("setpgid failed: %s", strerror(errno));
45@@ -392,7 +392,7 @@ int parse_args(const int argc, char* const argv[], char* (**child_args_ptr_ptr)[
46 return 0;
47 }
48
49-int parse_env() {
50+int parse_env(void) {
51 #if HAS_SUBREAPER
52 if (getenv(SUBREAPER_ENV_VAR) != NULL) {
53 subreaper++;
54@@ -413,7 +413,7 @@ int parse_env() {
55
56
57 #if HAS_SUBREAPER
58-int register_subreaper () {
59+int register_subreaper (void) {
60 if (subreaper > 0) {
61 if (prctl(PR_SET_CHILD_SUBREAPER, 1)) {
62 if (errno == EINVAL) {
63@@ -431,7 +431,7 @@ int register_subreaper () {
64 #endif
65
66
67-void reaper_check () {
68+void reaper_check (void) {
69 /* Check that we can properly reap zombies */
70 #if HAS_SUBREAPER
71 int bit = 0;
72--
732.34.1
74
diff --git a/recipes-containers/tini/tini_0.19.0.bb b/recipes-containers/tini/tini_0.19.0.bb
index 914cffbf..fd90f620 100644
--- a/recipes-containers/tini/tini_0.19.0.bb
+++ b/recipes-containers/tini/tini_0.19.0.bb
@@ -8,6 +8,7 @@ SRCREV = "b9f42a0e7bb46efea0c9e3d8610c96ab53b467f8"
8SRC_URI = " \ 8SRC_URI = " \
9 git://github.com/krallin/tini.git;branch=master;protocol=https \ 9 git://github.com/krallin/tini.git;branch=master;protocol=https \
10 file://0001-Do-not-strip-the-output-binary-allow-yocto-to-do-thi.patch \ 10 file://0001-Do-not-strip-the-output-binary-allow-yocto-to-do-thi.patch \
11 file://0001-tini.c-a-function-declaration-without-a-prototype-is.patch \
11 " 12 "
12 13
13LICENSE = "MIT" 14LICENSE = "MIT"