summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-07-30 17:09:43 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-08-02 22:57:14 -0400
commit67c011572a6b700ea8eeee14ef37fe9c894f06e3 (patch)
tree018b89249ce539e44e4df446b6172bdbffab2683
parentb1c810c812cc57691659a13b75fba2d0620fa70c (diff)
downloadmeta-virtualization-67c011572a6b700ea8eeee14ef37fe9c894f06e3.tar.gz
criu: uprev to version 3.10
A fairly straightforward uprev requiring minimal patch refreshing since a few hunks were failing due to conflicts with upstream updates. Unfortunately upstream starting using the now overloaded "PYTHON" variable in their Makefiles, this is not the path to the python executable but rather the name 'python2' or 'python3' which is used to determine which local directories to include. Due to this we must explicitly assign values to 'PYTHON_FULL' and 'PYTHON'. We use 'python2' since we are using 'setuptools' and therefore are explicitly using python v2, at some point we might want to make this recipe work with either python v2 or v3 but for now we continue to explicitly use v2. Instead of using version specific filename we switch to using _git.bb which is inline with similar 'git' recipes found in oe-core and other repos. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-containers/criu/criu_git.bb (renamed from recipes-containers/criu/criu_3.9.bb)8
-rw-r--r--recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch13
-rw-r--r--recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch6
3 files changed, 14 insertions, 13 deletions
diff --git a/recipes-containers/criu/criu_3.9.bb b/recipes-containers/criu/criu_git.bb
index 36c356db..00de417b 100644
--- a/recipes-containers/criu/criu_3.9.bb
+++ b/recipes-containers/criu/criu_git.bb
@@ -13,8 +13,8 @@ EXCLUDE_FROM_WORLD = "1"
13 13
14LIC_FILES_CHKSUM = "file://COPYING;md5=412de458544c1cb6a2b512cd399286e2" 14LIC_FILES_CHKSUM = "file://COPYING;md5=412de458544c1cb6a2b512cd399286e2"
15 15
16SRCREV = "202b7745bd0c37a1732ebe2fb009a157d338bf95" 16SRCREV = "c49eab368a68682475c4e693258246e04232e6d2"
17PV = "3.9+git${SRCPV}" 17PV = "3.10+git${SRCPV}"
18 18
19SRC_URI = "git://github.com/xemul/criu.git;protocol=git \ 19SRC_URI = "git://github.com/xemul/criu.git;protocol=git \
20 file://0001-criu-Fix-toolchain-hardcode.patch \ 20 file://0001-criu-Fix-toolchain-hardcode.patch \
@@ -67,12 +67,12 @@ do_compile_prepend() {
67} 67}
68 68
69do_compile () { 69do_compile () {
70 oe_runmake 70 oe_runmake FULL_PYTHON=${PYTHON} PYTHON=python2
71} 71}
72 72
73do_install () { 73do_install () {
74 export INSTALL_LIB="${libdir}/${PYTHON_DIR}/site-packages" 74 export INSTALL_LIB="${libdir}/${PYTHON_DIR}/site-packages"
75 oe_runmake PREFIX=${exec_prefix} LIBDIR=${libdir} DESTDIR="${D}" install 75 oe_runmake PREFIX=${exec_prefix} LIBDIR=${libdir} DESTDIR="${D}" FULL_PYTHON=${PYTHON} PYTHON=python2 install
76} 76}
77 77
78FILES_${PN} += "${systemd_unitdir}/ \ 78FILES_${PN} += "${systemd_unitdir}/ \
diff --git a/recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch b/recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch
index d1f136c4..838cbdc9 100644
--- a/recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch
+++ b/recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch
@@ -33,7 +33,7 @@ diff --git a/scripts/nmk/scripts/include.mk b/scripts/nmk/scripts/include.mk
33index 04ccb3a..0d63bc7 100644 33index 04ccb3a..0d63bc7 100644
34--- a/scripts/nmk/scripts/include.mk 34--- a/scripts/nmk/scripts/include.mk
35+++ b/scripts/nmk/scripts/include.mk 35+++ b/scripts/nmk/scripts/include.mk
36@@ -20,7 +20,7 @@ SUBARCH := $(shell uname -m | sed \ 36@@ -22,7 +22,7 @@ SUBARCH := $(shell uname -m | sed \
37 -e s/aarch64.*/aarch64/) 37 -e s/aarch64.*/aarch64/)
38 38
39 ARCH ?= $(SUBARCH) 39 ARCH ?= $(SUBARCH)
@@ -46,7 +46,7 @@ diff --git a/scripts/nmk/scripts/tools.mk b/scripts/nmk/scripts/tools.mk
46index 56dba84..1698821 100644 46index 56dba84..1698821 100644
47--- a/scripts/nmk/scripts/tools.mk 47--- a/scripts/nmk/scripts/tools.mk
48+++ b/scripts/nmk/scripts/tools.mk 48+++ b/scripts/nmk/scripts/tools.mk
49@@ -2,30 +2,30 @@ ifndef ____nmk_defined__tools 49@@ -2,31 +2,31 @@ ifndef ____nmk_defined__tools
50 50
51 # 51 #
52 # System tools shorthands 52 # System tools shorthands
@@ -68,9 +68,7 @@ index 56dba84..1698821 100644
68-MKDIR := mkdir -p 68-MKDIR := mkdir -p
69-AWK := awk 69-AWK := awk
70-PERL := perl 70-PERL := perl
71-PYTHON := python 71-FULL_PYTHON := $(shell which python2 2>/dev/null || which python3 2>/dev/null)
72-FIND := find
73-SH := $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
74+CC ?= $(CROSS_COMPILE)$(HOSTCC) 72+CC ?= $(CROSS_COMPILE)$(HOSTCC)
75+CPP ?= $(CC) -E 73+CPP ?= $(CC) -E
76+AS ?= $(CROSS_COMPILE)as 74+AS ?= $(CROSS_COMPILE)as
@@ -83,7 +81,10 @@ index 56dba84..1698821 100644
83+MKDIR ?= mkdir -p 81+MKDIR ?= mkdir -p
84+AWK ?= awk 82+AWK ?= awk
85+PERL ?= perl 83+PERL ?= perl
86+PYTHON ?= python 84+FULL_PYTHON ?= $(shell which python2 2>/dev/null || which python3 2>/dev/null)
85 PYTHON ?= $(shell basename $(FULL_PYTHON))
86-FIND := find
87-SH := $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
87+FIND ?= find 88+FIND ?= find
88+SH ?= $(shell if [ -x "$$BASH" ]; then echo $$BASH; \ 89+SH ?= $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
89 else if [ -x /bin/bash ]; then echo /bin/bash; \ 90 else if [ -x /bin/bash ]; then echo /bin/bash; \
diff --git a/recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch b/recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch
index 59e7bcbf..70ccb287 100644
--- a/recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch
+++ b/recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch
@@ -17,12 +17,12 @@ diff --git a/lib/Makefile b/lib/Makefile
17index b1bb057..06f5c5d 100644 17index b1bb057..06f5c5d 100644
18--- a/lib/Makefile 18--- a/lib/Makefile
19+++ b/lib/Makefile 19+++ b/lib/Makefile
20@@ -56,7 +56,7 @@ install: lib-c lib-py crit/crit lib/c/criu.pc.in 20@@ -53,7 +53,7 @@ install: lib-c lib-py crit/crit lib/c/criu.pc.in
21 $(Q) sed -e 's,@version@,$(CRIU_VERSION),' -e 's,@libdir@,$(LIBDIR),' -e 's,@includedir@,$(dir $(INCLUDEDIR)/criu/),' lib/c/criu.pc.in > lib/c/criu.pc 21 $(Q) sed -e 's,@version@,$(CRIU_VERSION),' -e 's,@libdir@,$(LIBDIR),' -e 's,@includedir@,$(dir $(INCLUDEDIR)/criu/),' lib/c/criu.pc.in > lib/c/criu.pc
22 $(Q) install -m 644 lib/c/criu.pc $(DESTDIR)$(LIBDIR)/pkgconfig 22 $(Q) install -m 644 lib/c/criu.pc $(DESTDIR)$(LIBDIR)/pkgconfig
23 $(E) " INSTALL " crit 23 $(E) " INSTALL " crit
24- $(Q) $(PYTHON_BIN) scripts/crit-setup.py install --prefix=$(DESTDIR)$(PREFIX) --record $(CRIT_SETUP_FILES) 24- $(Q) $(PYTHON) scripts/crit-setup.py install --prefix=$(DESTDIR)$(PREFIX) --record $(CRIT_SETUP_FILES)
25+ $(Q) $(PYTHON_BIN) scripts/crit-setup.py install --prefix=$(DESTDIR)$(PREFIX) --record $(CRIT_SETUP_FILES) --install-lib=$(DESTDIR)$(INSTALL_LIB) 25+ $(Q) $(PYTHON) scripts/crit-setup.py install --prefix=$(DESTDIR)$(PREFIX) --record $(CRIT_SETUP_FILES) --install-lib=$(DESTDIR)$(INSTALL_LIB)
26 .PHONY: install 26 .PHONY: install
27 27
28 uninstall: 28 uninstall: