summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHe Zhe <zhe.he@windriver.com>2015-09-08 14:55:12 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-09-08 10:01:55 -0400
commit62e49b861f211312a16367e9b032dfa097fab7d6 (patch)
tree3cdc6df1ec20551996db19de93ef97fd2e45854e
parente9ac83952d3a5d119ee2aae8ed14795cb0a38c43 (diff)
downloadmeta-virtualization-62e49b861f211312a16367e9b032dfa097fab7d6.tar.gz
linux-yocto: Add bbappend for 4.1 for virtualization configuration
Signed-off-by: He Zhe <zhe.he@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-kernel/linux/linux-yocto_4.1.bbappend19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-yocto_4.1.bbappend b/recipes-kernel/linux/linux-yocto_4.1.bbappend
new file mode 100644
index 00000000..85e98cc6
--- /dev/null
+++ b/recipes-kernel/linux/linux-yocto_4.1.bbappend
@@ -0,0 +1,19 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += "file://xt-checksum.scc \
4 file://ebtables.scc \
5 file://vswitch.scc \
6 file://lxc.scc \
7 "
8KERNEL_FEATURES_append = " features/kvm/qemu-kvm-enable.scc"
9
10KERNEL_MODULE_AUTOLOAD += "openvswitch"
11KERNEL_MODULE_AUTOLOAD += "kvm"
12KERNEL_MODULE_AUTOLOAD += "kvm-amd"
13KERNEL_MODULE_AUTOLOAD += "kvm-intel"
14
15# aufs kernel support required for xen-image-minimal
16KERNEL_FEATURES_append += "${@base_contains('DISTRO_FEATURES', 'aufs', ' features/aufs/aufs-enable.scc', '', d)}"
17
18# xen kernel support
19SRC_URI += "${@base_contains('DISTRO_FEATURES', 'xen', ' file://xen.scc', '', d)}"