summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChandana kalluri <ckalluri@xilinx.com>2020-04-08 09:52:41 -0700
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-04-08 23:07:43 -0400
commit62466a75a95e2b2b936ea70920853d46b1f6ba70 (patch)
tree5bff7a7e1c57a47884d180280f45495ee5e53e50
parent16134e66ca8863869a8c69924daeae9dc6eb56bf (diff)
downloadmeta-virtualization-62466a75a95e2b2b936ea70920853d46b1f6ba70.tar.gz
go-build_git.bb: go-build: set GO_PARALLEL_BUILD to default value
Set GO_PARALLEL_BUILD to default to prevent the following error: failed to create new OS thread (have 13 already; errno=11) runtime: may need to increase max user processes (ulimit -u) fatal error: newosproc Signed-off-by: Sai Hari Chandana Kalluri <chandana.kalluri@xilinx.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@xilinx.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-devtools/go/go-build_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-devtools/go/go-build_git.bb b/recipes-devtools/go/go-build_git.bb
index f94a7225..e057b6d7 100644
--- a/recipes-devtools/go/go-build_git.bb
+++ b/recipes-devtools/go/go-build_git.bb
@@ -20,6 +20,7 @@ PV = "0.1-git${SRCREV_runx}"
20 20
21inherit features_check 21inherit features_check
22REQUIRED_DISTRO_FEATURES = "vmsep" 22REQUIRED_DISTRO_FEATURES = "vmsep"
23GO_PARALLEL_BUILD ?= "${@oe.utils.parallel_make_argument(d, '-p %d')}"
23 24
24inherit pkgconfig 25inherit pkgconfig
25 26