summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-11-01 10:38:23 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-11-02 21:21:27 -0400
commit60142aa29ab77695f557737293d19d47bff7eeef (patch)
treeb7e2732a3054edfeeba38c91ec051b303342b1f5
parent4bded63c2ec35a6c2aa3276f83519925e8669663 (diff)
downloadmeta-virtualization-60142aa29ab77695f557737293d19d47bff7eeef.tar.gz
kubernetes: uprev to v1.12 release and fix cross compilation errors
The update to go 1.11 exposed some issues with the cross compilation of kubernetes. The best way to fix those issues is to uprev to 1.12 and to inhibit the building of the test modules (which query the host for infrastructure that is not present). Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-containers/kubernetes/kubernetes/0001-cross-don-t-build-tests-by-default.patch33
-rw-r--r--recipes-containers/kubernetes/kubernetes_git.bb7
2 files changed, 37 insertions, 3 deletions
diff --git a/recipes-containers/kubernetes/kubernetes/0001-cross-don-t-build-tests-by-default.patch b/recipes-containers/kubernetes/kubernetes/0001-cross-don-t-build-tests-by-default.patch
new file mode 100644
index 00000000..659e3013
--- /dev/null
+++ b/recipes-containers/kubernetes/kubernetes/0001-cross-don-t-build-tests-by-default.patch
@@ -0,0 +1,33 @@
1From fa912b53186a047d787c8c456156b9dbdcdf040d Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@windriver.com>
3Date: Thu, 1 Nov 2018 10:21:10 -0400
4Subject: [PATCH] cross: don't build tests by default
5
6The hack/* build infrastructure doesn't respect the WHAT= commands
7that the make infrastructure provides to limit what is built.
8
9In our case, we are cross building and can't build the server test
10components without error. As such, we patch the targets out of the
11script to allow a successful build.
12
13Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
14---
15 hack/make-rules/cross.sh | 4 ++--
16 1 file changed, 2 insertions(+), 2 deletions(-)
17
18diff --git a/src/import/hack/make-rules/cross.sh b/hack/make-rules/cross.sh
19index 8e1e938..0898c5c 100755
20--- a/src/import/hack/make-rules/cross.sh
21+++ b/src/import/hack/make-rules/cross.sh
22@@ -33,6 +33,6 @@ make all WHAT="${KUBE_NODE_TARGETS[*]}" KUBE_BUILD_PLATFORMS="${KUBE_NODE_PLATFO
23
24 make all WHAT="${KUBE_CLIENT_TARGETS[*]}" KUBE_BUILD_PLATFORMS="${KUBE_CLIENT_PLATFORMS[*]}"
25
26-make all WHAT="${KUBE_TEST_TARGETS[*]}" KUBE_BUILD_PLATFORMS="${KUBE_TEST_PLATFORMS[*]}"
27+#make all WHAT="${KUBE_TEST_TARGETS[*]}" KUBE_BUILD_PLATFORMS="${KUBE_TEST_PLATFORMS[*]}"
28
29-make all WHAT="${KUBE_TEST_SERVER_TARGETS[*]}" KUBE_BUILD_PLATFORMS="${KUBE_TEST_SERVER_PLATFORMS[*]}"
30+#make all WHAT="${KUBE_TEST_SERVER_TARGETS[*]}" KUBE_BUILD_PLATFORMS="${KUBE_TEST_SERVER_PLATFORMS[*]}"
31--
322.7.4
33
diff --git a/recipes-containers/kubernetes/kubernetes_git.bb b/recipes-containers/kubernetes/kubernetes_git.bb
index a7e9bf90..c3810b0d 100644
--- a/recipes-containers/kubernetes/kubernetes_git.bb
+++ b/recipes-containers/kubernetes/kubernetes_git.bb
@@ -7,11 +7,12 @@ maintenance, and scaling of applications. \
7 7
8# Note: 1.11+ requires go 1.10.2+, so the following must be set 8# Note: 1.11+ requires go 1.10.2+, so the following must be set
9# in your configuration: GOVERSION = "1.10%" 9# in your configuration: GOVERSION = "1.10%"
10PV = "1.11.0+git${SRCREV_kubernetes}" 10PV = "1.12.0+git${SRCREV_kubernetes}"
11SRCREV_kubernetes = "210c9cd7e1782e9fe46938fe0368556f2166a528" 11SRCREV_kubernetes = "d93ba8b6d1e2afcb30da3e354928ed00e6682223"
12 12
13SRC_URI = "git://github.com/kubernetes/kubernetes.git;branch=release-1.11;name=kubernetes \ 13SRC_URI = "git://github.com/kubernetes/kubernetes.git;branch=release-1.12;name=kubernetes \
14 file://0001-hack-lib-golang.sh-use-CC-from-environment.patch \ 14 file://0001-hack-lib-golang.sh-use-CC-from-environment.patch \
15 file://0001-cross-don-t-build-tests-by-default.patch \
15 " 16 "
16 17
17DEPENDS += "rsync-native \ 18DEPENDS += "rsync-native \