summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartosz Golaszewski <brgl@bgdev.pl>2021-03-29 20:59:55 +0200
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-03-30 16:43:47 -0400
commit5be55ac5cfb266d01bfa272f4c94832b21eb7ad4 (patch)
tree4f38617e4e0ae272cd7e05ce1e753c96e3b5fbde
parent2e5f311548cf78dd6755ebffb5c8af9ee3ba98f0 (diff)
downloadmeta-virtualization-5be55ac5cfb266d01bfa272f4c94832b21eb7ad4.tar.gz
boto3: satisfy runtime dependencies
Currently boto3 can be built into an image but it won't work without additional dependencies. First: botocore is needed at run-time, second: there are other packages available in meta-python that need adding. Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-devtools/python/python3-boto3_1.14.7.bb2
-rw-r--r--recipes-devtools/python/python3-botocore_1.20.36.bb12
2 files changed, 14 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-boto3_1.14.7.bb b/recipes-devtools/python/python3-boto3_1.14.7.bb
index f9e979e8..0e9611ca 100644
--- a/recipes-devtools/python/python3-boto3_1.14.7.bb
+++ b/recipes-devtools/python/python3-boto3_1.14.7.bb
@@ -13,3 +13,5 @@ SRC_URI[md5sum] = "fb8b77d4ac10a971570419dd3613196e"
13SRC_URI[sha256sum] = "4856c8cb4150b900cc7dccbdf16f542fb8c12e97b17639979e58760847f7cf35" 13SRC_URI[sha256sum] = "4856c8cb4150b900cc7dccbdf16f542fb8c12e97b17639979e58760847f7cf35"
14 14
15inherit pypi setuptools3 15inherit pypi setuptools3
16
17RDEPENDS_${PN} += "python3-botocore python3-urllib3 python3-unixadmin"
diff --git a/recipes-devtools/python/python3-botocore_1.20.36.bb b/recipes-devtools/python/python3-botocore_1.20.36.bb
new file mode 100644
index 00000000..4c4a8251
--- /dev/null
+++ b/recipes-devtools/python/python3-botocore_1.20.36.bb
@@ -0,0 +1,12 @@
1SUMMARY = "The low-level, core functionality of boto 3."
2HOMEPAGE = "https://github.com/boto/botocore"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2ee41112a44fe7014dce33e26468ba93"
5
6SRC_URI = "git://github.com/boto/botocore.git;protocol=https"
7SRCREV = "8c7123bd4683049dcac62bf3e11662e6a72c5eec"
8S = "${WORKDIR}/git"
9
10inherit setuptools3
11
12RDEPENDS_${PN} += "python3-jmespath python3-dateutil python3-logging"