summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Barker <pbarker@toganlabs.com>2017-10-04 10:40:26 +0000
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-10-04 16:54:33 -0400
commit44e74c9aa74c818181058f6d4b660309b35c6db4 (patch)
tree7d0095d77e54440e7886eac2c20e0c9a4337270f
parent83592435dcf23f99327f1f3a276302e5c91839f9 (diff)
downloadmeta-virtualization-44e74c9aa74c818181058f6d4b660309b35c6db4.tar.gz
runc-opencontainers: go.bbclass compile fixes
These fixes are needed due to updates to go.bbclass in oe-core. See commit 01a8d4537012ad93dc8510e9b762acdc8c4536c7 for more information. Signed-off-by: Paul Barker <pbarker@toganlabs.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-containers/runc/runc-opencontainers_git.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes-containers/runc/runc-opencontainers_git.bb b/recipes-containers/runc/runc-opencontainers_git.bb
index 940ae952..902a93da 100644
--- a/recipes-containers/runc/runc-opencontainers_git.bb
+++ b/recipes-containers/runc/runc-opencontainers_git.bb
@@ -6,9 +6,11 @@ RUNC_VERSION = "1.0.0-rc4"
6PROVIDES += "virtual/runc" 6PROVIDES += "virtual/runc"
7RPROVIDES_${PN} = "virtual/runc" 7RPROVIDES_${PN} = "virtual/runc"
8 8
9GO_IMPORT = "import"
10
9do_compile_prepend() { 11do_compile_prepend() {
10 # Go looks in a src directory under any directory in GOPATH but 12 # Go looks in a src directory under any directory in GOPATH but
11 # runc-opencontainers uses 'vendor' instead of 'vendor/src'. We can fix 13 # runc-opencontainers uses 'vendor' instead of 'vendor/src'. We can fix
12 # this with a symlink. 14 # this with a symlink.
13 ln -sfn . "${S}/vendor/src" 15 ln -sfn . "${S}/src/import/vendor/src"
14} 16}