summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-08-17 16:43:28 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-08-20 11:35:48 -0400
commit2c8e62d5b446d9bb167df317bc47111fdee0df33 (patch)
tree2bf79f837d74d78677c73f97e556978faa9d1ee3
parentcdd4241dd7a122418b3bb70b7c4e940f6dbca3b4 (diff)
downloadmeta-virtualization-2c8e62d5b446d9bb167df317bc47111fdee0df33.tar.gz
libvirt: uprev to v4.5.0
Although v4.6.0 was just recently released we do not want to jump to it due to: https://bugzilla.redhat.com/show_bug.cgi?id=1614569 Unfortunately the mess around the above defect basically renders that release useless. We will need to keep an eye for either a v4.7.0 or grab updates off of the 'v4.5-maint' over the coming weeks. As usual I have tested using qemu and lxc usecases (define, boot and 'virsh console' onto a guest). The ptests results match those of v4.3.0: ====================================== Testsuite summary for libvirt 4.5.0 ====================================== # TOTAL: 119 # PASS: 114 # SKIP: 0 # XFAIL: 0 # FAIL: 5 # XPASS: 0 # ERROR: 0 Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-extended/libvirt/libvirt-python.inc4
-rw-r--r--recipes-extended/libvirt/libvirt_4.5.0.bb (renamed from recipes-extended/libvirt/libvirt_4.3.0.bb)4
2 files changed, 4 insertions, 4 deletions
diff --git a/recipes-extended/libvirt/libvirt-python.inc b/recipes-extended/libvirt/libvirt-python.inc
index 79beb95a..cdc5719c 100644
--- a/recipes-extended/libvirt/libvirt-python.inc
+++ b/recipes-extended/libvirt/libvirt-python.inc
@@ -18,8 +18,8 @@ FILES_${PN}-python = "${bindir}/* ${libdir}/* ${libdir}/${PYTHON_DIR}/*"
18SRC_URI += "http://libvirt.org/sources/python/libvirt-python-${PV}.tar.gz;name=libvirt_python" 18SRC_URI += "http://libvirt.org/sources/python/libvirt-python-${PV}.tar.gz;name=libvirt_python"
19SRC_URI += "file://libvirt_api_xml_path.patch;patchdir=../libvirt-python-${PV}" 19SRC_URI += "file://libvirt_api_xml_path.patch;patchdir=../libvirt-python-${PV}"
20 20
21SRC_URI[libvirt_python.md5sum] = "2ea5f1871358e6a5788b52c2e1a0b809" 21SRC_URI[libvirt_python.md5sum] = "0c1b66a8878d6436b036565060707f73"
22SRC_URI[libvirt_python.sha256sum] = "efe384479a0bf74b1b83bba208887b263cc0061fd4f87759cf3067a403618ea9" 22SRC_URI[libvirt_python.sha256sum] = "ef35ed6bc24d76563b1ba9b068ef5a048016726dba62a9d057fe6dfbea6b0f60"
23 23
24export LIBVIRT_API_PATH = "${S}/docs/libvirt-api.xml" 24export LIBVIRT_API_PATH = "${S}/docs/libvirt-api.xml"
25export LIBVIRT_CFLAGS = "-I${S}/include" 25export LIBVIRT_CFLAGS = "-I${S}/include"
diff --git a/recipes-extended/libvirt/libvirt_4.3.0.bb b/recipes-extended/libvirt/libvirt_4.5.0.bb
index bb4a256e..9cfa74a3 100644
--- a/recipes-extended/libvirt/libvirt_4.3.0.bb
+++ b/recipes-extended/libvirt/libvirt_4.5.0.bb
@@ -37,8 +37,8 @@ SRC_URI = "http://libvirt.org/sources/libvirt-${PV}.tar.xz;name=libvirt \
37 file://configure.ac-search-for-rpc-rpc.h-in-the-sysroot.patch \ 37 file://configure.ac-search-for-rpc-rpc.h-in-the-sysroot.patch \
38 " 38 "
39 39
40SRC_URI[libvirt.md5sum] = "946cfa2558401612c4fcbc934ef9077b" 40SRC_URI[libvirt.md5sum] = "692b2d00907438ed08a68813d3177cd3"
41SRC_URI[libvirt.sha256sum] = "a531e22c8b985ecb2d1223b913fd6ec0f1800e3ebe02351924274885db20c2b7" 41SRC_URI[libvirt.sha256sum] = "e7e95edc0ca553046761ed55a8d01a06a3a3a4238bbeaedb3ba34680a277ab09"
42 42
43inherit autotools gettext update-rc.d pkgconfig ptest systemd 43inherit autotools gettext update-rc.d pkgconfig ptest systemd
44 44