summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2024-02-28 14:14:37 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2024-03-15 17:17:19 +0000
commit2961677b6a97bd3e93aa879503537f611f0202d4 (patch)
treeca59e9e7996ba81d79b75bdff835b4b6f379a923
parent81047284368dd905f0db16b4182e42a22a70ba26 (diff)
downloadmeta-virtualization-2961677b6a97bd3e93aa879503537f611f0202d4.tar.gz
devtools: depreciate the go source-only packages
We are now using vendoring from the upstream repos, or creating our own vendor directory. We no longer need these source only recipes. Add an inherit to each recipe to warn that it will be removed in the future. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/go-digest/go-digest_git.bb2
-rw-r--r--recipes-containers/go-errors/go-errors_git.bb2
-rw-r--r--recipes-containers/go-spf13-cobra/spf13-cobra_git.bb2
-rw-r--r--recipes-containers/go-spf13-pflag/spf13-pflag_git.bb2
-rw-r--r--recipes-devtools/go/go-capability_git.bb2
-rw-r--r--recipes-devtools/go/go-cli_git.bb2
-rw-r--r--recipes-devtools/go/go-connections_git.bb2
-rw-r--r--recipes-devtools/go/go-context_git.bb2
-rw-r--r--recipes-devtools/go/go-dbus_git.bb2
-rw-r--r--recipes-devtools/go/go-distribution_git.bb2
-rw-r--r--recipes-devtools/go/go-fsnotify_git.bb2
-rw-r--r--recipes-devtools/go/go-libtrust_git.bb2
-rw-r--r--recipes-devtools/go/go-logrus_git.bb2
-rw-r--r--recipes-devtools/go/go-mux_git.bb2
-rw-r--r--recipes-devtools/go/go-patricia_git.bb2
-rw-r--r--recipes-devtools/go/go-pty_git.bb2
-rw-r--r--recipes-devtools/go/go-systemd_git.bb2
-rw-r--r--recipes-devtools/go/notary_git.bb2
18 files changed, 36 insertions, 0 deletions
diff --git a/recipes-containers/go-digest/go-digest_git.bb b/recipes-containers/go-digest/go-digest_git.bb
index a231cf7b..a1be705d 100644
--- a/recipes-containers/go-digest/go-digest_git.bb
+++ b/recipes-containers/go-digest/go-digest_git.bb
@@ -18,6 +18,8 @@ S = "${WORKDIR}/git"
18do_compile() { 18do_compile() {
19} 19}
20 20
21inherit meta-virt-depreciated-warning
22
21do_install() { 23do_install() {
22 install -d ${D}${prefix}/local/go/src/${PKG_NAME} 24 install -d ${D}${prefix}/local/go/src/${PKG_NAME}
23 for j in $(cd ${S} && find src/${PKG_NAME} -name "*.go"); do 25 for j in $(cd ${S} && find src/${PKG_NAME} -name "*.go"); do
diff --git a/recipes-containers/go-errors/go-errors_git.bb b/recipes-containers/go-errors/go-errors_git.bb
index 87486358..1236bb7b 100644
--- a/recipes-containers/go-errors/go-errors_git.bb
+++ b/recipes-containers/go-errors/go-errors_git.bb
@@ -18,6 +18,8 @@ S = "${WORKDIR}/git"
18do_compile() { 18do_compile() {
19} 19}
20 20
21inherit meta-virt-depreciated-warning
22
21do_install() { 23do_install() {
22 install -d ${D}${prefix}/local/go/src/${PKG_NAME} 24 install -d ${D}${prefix}/local/go/src/${PKG_NAME}
23 for j in $(cd ${S} && find src/${PKG_NAME} -name "*.go" -not -path "*/.tool/*"); do 25 for j in $(cd ${S} && find src/${PKG_NAME} -name "*.go" -not -path "*/.tool/*"); do
diff --git a/recipes-containers/go-spf13-cobra/spf13-cobra_git.bb b/recipes-containers/go-spf13-cobra/spf13-cobra_git.bb
index c6629014..8dfb0692 100644
--- a/recipes-containers/go-spf13-cobra/spf13-cobra_git.bb
+++ b/recipes-containers/go-spf13-cobra/spf13-cobra_git.bb
@@ -18,6 +18,8 @@ S = "${WORKDIR}/git"
18do_compile() { 18do_compile() {
19} 19}
20 20
21inherit meta-virt-depreciated-warning
22
21do_install() { 23do_install() {
22 install -d ${D}${prefix}/local/go/src/${PKG_NAME} 24 install -d ${D}${prefix}/local/go/src/${PKG_NAME}
23 for j in $(cd ${S} && find src/${PKG_NAME} -name "*.go" -not -path "*/.tool/*"); do 25 for j in $(cd ${S} && find src/${PKG_NAME} -name "*.go" -not -path "*/.tool/*"); do
diff --git a/recipes-containers/go-spf13-pflag/spf13-pflag_git.bb b/recipes-containers/go-spf13-pflag/spf13-pflag_git.bb
index 201f183a..b3e41545 100644
--- a/recipes-containers/go-spf13-pflag/spf13-pflag_git.bb
+++ b/recipes-containers/go-spf13-pflag/spf13-pflag_git.bb
@@ -18,6 +18,8 @@ S = "${WORKDIR}/git"
18do_compile() { 18do_compile() {
19} 19}
20 20
21inherit meta-virt-depreciated-warning
22
21do_install() { 23do_install() {
22 install -d ${D}${prefix}/local/go/src/${PKG_NAME} 24 install -d ${D}${prefix}/local/go/src/${PKG_NAME}
23 for j in $(cd ${S} && find src/${PKG_NAME} -name "*.go" -not -path "*/.tool/*"); do 25 for j in $(cd ${S} && find src/${PKG_NAME} -name "*.go" -not -path "*/.tool/*"); do
diff --git a/recipes-devtools/go/go-capability_git.bb b/recipes-devtools/go/go-capability_git.bb
index e01a83d1..c2562474 100644
--- a/recipes-devtools/go/go-capability_git.bb
+++ b/recipes-devtools/go/go-capability_git.bb
@@ -12,6 +12,8 @@ SRC_URI = "git://${PKG_NAME}.git;branch=master;protocol=https"
12SRCREV = "2c00daeb6c3b45114c80ac44119e7b8801fdd852" 12SRCREV = "2c00daeb6c3b45114c80ac44119e7b8801fdd852"
13PV = "0.0+git" 13PV = "0.0+git"
14 14
15inherit meta-virt-depreciated-warning
16
15S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
16 18
17do_install() { 19do_install() {
diff --git a/recipes-devtools/go/go-cli_git.bb b/recipes-devtools/go/go-cli_git.bb
index affe38ec..8a4992bd 100644
--- a/recipes-devtools/go/go-cli_git.bb
+++ b/recipes-devtools/go/go-cli_git.bb
@@ -14,6 +14,8 @@ PV = "1.1.0+git"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
17inherit meta-virt-depreciated-warning
18
17do_install() { 19do_install() {
18 install -d ${D}${prefix}/local/go/src/${PKG_NAME} 20 install -d ${D}${prefix}/local/go/src/${PKG_NAME}
19 cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ 21 cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/
diff --git a/recipes-devtools/go/go-connections_git.bb b/recipes-devtools/go/go-connections_git.bb
index 7e8f020d..33bb83bf 100644
--- a/recipes-devtools/go/go-connections_git.bb
+++ b/recipes-devtools/go/go-connections_git.bb
@@ -14,6 +14,8 @@ PV = "0.2.1+git"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
17inherit meta-virt-depreciated-warning
18
17# NO-OP the do compile rule because this recipe is source only. 19# NO-OP the do compile rule because this recipe is source only.
18do_compile() { 20do_compile() {
19} 21}
diff --git a/recipes-devtools/go/go-context_git.bb b/recipes-devtools/go/go-context_git.bb
index 580463d3..02f57875 100644
--- a/recipes-devtools/go/go-context_git.bb
+++ b/recipes-devtools/go/go-context_git.bb
@@ -13,6 +13,8 @@ SRCREV = "1cbd4c16de64273a6e63fc710b0d89bfad72cd32"
13 13
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
15 15
16inherit meta-virt-depreciated-warning
17
16do_compile() { 18do_compile() {
17 true 19 true
18} 20}
diff --git a/recipes-devtools/go/go-dbus_git.bb b/recipes-devtools/go/go-dbus_git.bb
index 49b2de3b..bc8691c4 100644
--- a/recipes-devtools/go/go-dbus_git.bb
+++ b/recipes-devtools/go/go-dbus_git.bb
@@ -14,6 +14,8 @@ PV = "4.0.0+git"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
17inherit meta-virt-depreciated-warning
18
17do_install() { 19do_install() {
18 install -d ${D}${prefix}/local/go/src/${PKG_NAME} 20 install -d ${D}${prefix}/local/go/src/${PKG_NAME}
19 cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ 21 cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/
diff --git a/recipes-devtools/go/go-distribution_git.bb b/recipes-devtools/go/go-distribution_git.bb
index dd98a317..598df964 100644
--- a/recipes-devtools/go/go-distribution_git.bb
+++ b/recipes-devtools/go/go-distribution_git.bb
@@ -14,6 +14,8 @@ PV = "2.6.0+git"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
17inherit meta-virt-depreciated-warning
18
17# NO-OP the do compile rule because this recipe is source only. 19# NO-OP the do compile rule because this recipe is source only.
18do_compile() { 20do_compile() {
19} 21}
diff --git a/recipes-devtools/go/go-fsnotify_git.bb b/recipes-devtools/go/go-fsnotify_git.bb
index 052658b8..b934ae9a 100644
--- a/recipes-devtools/go/go-fsnotify_git.bb
+++ b/recipes-devtools/go/go-fsnotify_git.bb
@@ -14,6 +14,8 @@ PV = "v1.5.1+git"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
17inherit meta-virt-depreciated-warning
18
17do_install() { 19do_install() {
18 install -d ${D}${prefix}/local/go/src/${PKG_NAME} 20 install -d ${D}${prefix}/local/go/src/${PKG_NAME}
19 cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ 21 cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/
diff --git a/recipes-devtools/go/go-libtrust_git.bb b/recipes-devtools/go/go-libtrust_git.bb
index c578008a..17199856 100644
--- a/recipes-devtools/go/go-libtrust_git.bb
+++ b/recipes-devtools/go/go-libtrust_git.bb
@@ -14,6 +14,8 @@ PV = "0.0+git"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
17inherit meta-virt-depreciated-warning
18
17do_install() { 19do_install() {
18 install -d ${D}${prefix}/local/go/src/${PKG_NAME} 20 install -d ${D}${prefix}/local/go/src/${PKG_NAME}
19 cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ 21 cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/
diff --git a/recipes-devtools/go/go-logrus_git.bb b/recipes-devtools/go/go-logrus_git.bb
index 211d07c9..1826b893 100644
--- a/recipes-devtools/go/go-logrus_git.bb
+++ b/recipes-devtools/go/go-logrus_git.bb
@@ -14,6 +14,8 @@ PV = "0.11.0+git"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
17inherit meta-virt-depreciated-warning
18
17do_install() { 19do_install() {
18 install -d ${D}${prefix}/local/go/src/${PKG_NAME} 20 install -d ${D}${prefix}/local/go/src/${PKG_NAME}
19 cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ 21 cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/
diff --git a/recipes-devtools/go/go-mux_git.bb b/recipes-devtools/go/go-mux_git.bb
index 0d69fc58..0958617a 100644
--- a/recipes-devtools/go/go-mux_git.bb
+++ b/recipes-devtools/go/go-mux_git.bb
@@ -11,6 +11,8 @@ SRC_URI = "git://${PKG_NAME}.git;branch=main;protocol=https"
11 11
12SRCREV = "85123bf20e069b156415b871dea10517f6a8938a" 12SRCREV = "85123bf20e069b156415b871dea10517f6a8938a"
13 13
14inherit meta-virt-depreciated-warning
15
14S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
15 17
16do_configure[noexec] = "1" 18do_configure[noexec] = "1"
diff --git a/recipes-devtools/go/go-patricia_git.bb b/recipes-devtools/go/go-patricia_git.bb
index 0a3c3f35..c05da591 100644
--- a/recipes-devtools/go/go-patricia_git.bb
+++ b/recipes-devtools/go/go-patricia_git.bb
@@ -14,6 +14,8 @@ PV = "2.2.6+git"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
17inherit meta-virt-depreciated-warning
18
17do_install() { 19do_install() {
18 install -d ${D}${prefix}/local/go/src/${PKG_NAME} 20 install -d ${D}${prefix}/local/go/src/${PKG_NAME}
19 cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ 21 cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/
diff --git a/recipes-devtools/go/go-pty_git.bb b/recipes-devtools/go/go-pty_git.bb
index 132e82d1..d6aa95f6 100644
--- a/recipes-devtools/go/go-pty_git.bb
+++ b/recipes-devtools/go/go-pty_git.bb
@@ -13,6 +13,8 @@ SRCREV = "05017fcccf23c823bfdea560dcc958a136e54fb7"
13 13
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
15 15
16inherit meta-virt-depreciated-warning
17
16do_install() { 18do_install() {
17 install -d ${D}${prefix}/local/go/src/${PKG_NAME} 19 install -d ${D}${prefix}/local/go/src/${PKG_NAME}
18 cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ 20 cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/
diff --git a/recipes-devtools/go/go-systemd_git.bb b/recipes-devtools/go/go-systemd_git.bb
index 3aa837aa..e7e97b9e 100644
--- a/recipes-devtools/go/go-systemd_git.bb
+++ b/recipes-devtools/go/go-systemd_git.bb
@@ -16,6 +16,8 @@ RDEPENDS:${PN} += "bash"
16 16
17S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
18 18
19inherit meta-virt-depreciated-warning
20
19do_install() { 21do_install() {
20 install -d ${D}${prefix}/local/go/src/${PKG_NAME} 22 install -d ${D}${prefix}/local/go/src/${PKG_NAME}
21 cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ 23 cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/
diff --git a/recipes-devtools/go/notary_git.bb b/recipes-devtools/go/notary_git.bb
index 1b877d62..ace7174d 100644
--- a/recipes-devtools/go/notary_git.bb
+++ b/recipes-devtools/go/notary_git.bb
@@ -14,6 +14,8 @@ PV = "0.6.1+git"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
17inherit meta-virt-depreciated-warning
18
17# NO-OP the do compile rule because this recipe is source only. 19# NO-OP the do compile rule because this recipe is source only.
18do_compile() { 20do_compile() {
19} 21}