summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRalph Siemsen <ralph.siemsen@linaro.org>2021-04-28 11:44:11 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-04-29 23:11:34 -0400
commit2874482a0ef6f4dd784ca6759fe9783923c66799 (patch)
treeab2062989e1505b69decd612108932d01f3ea94d
parent3ac4e5f49d866b58d29befbd886e8901955185b3 (diff)
downloadmeta-virtualization-2874482a0ef6f4dd784ca6759fe9783923c66799.tar.gz
runc: add CVE_PRODUCT to recipes
Allows the yocto cve-checker to flag CVEs, which would otherwise go unreported due to the package name not matching NIST NVD data. Signed-off-by: Ralph Siemsen <ralph.siemsen@linaro.org> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/runc/runc-docker_git.bb2
-rw-r--r--recipes-containers/runc/runc-opencontainers_git.bb2
2 files changed, 4 insertions, 0 deletions
diff --git a/recipes-containers/runc/runc-docker_git.bb b/recipes-containers/runc/runc-docker_git.bb
index 8d810d01..3684366f 100644
--- a/recipes-containers/runc/runc-docker_git.bb
+++ b/recipes-containers/runc/runc-docker_git.bb
@@ -11,3 +11,5 @@ SRC_URI = "git://github.com/opencontainers/runc;nobranch=1;name=runc-docker \
11 " 11 "
12 12
13RUNC_VERSION = "1.0.0-rc8" 13RUNC_VERSION = "1.0.0-rc8"
14
15CVE_PRODUCT = "runc"
diff --git a/recipes-containers/runc/runc-opencontainers_git.bb b/recipes-containers/runc/runc-opencontainers_git.bb
index 3a7e7aaf..a1271f69 100644
--- a/recipes-containers/runc/runc-opencontainers_git.bb
+++ b/recipes-containers/runc/runc-opencontainers_git.bb
@@ -7,3 +7,5 @@ SRC_URI = " \
7 file://0001-Only-allow-proc-mount-if-it-is-procfs.patch \ 7 file://0001-Only-allow-proc-mount-if-it-is-procfs.patch \
8 " 8 "
9RUNC_VERSION = "1.0.0-rc8" 9RUNC_VERSION = "1.0.0-rc8"
10
11CVE_PRODUCT = "runc"