summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2024-03-02 14:10:30 -0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2024-03-15 17:17:20 +0000
commit227452ab4bb5b6518eb56def5a744ee9d4947cae (patch)
treed7aad22785a187b76ac446b66e50b99734c7463e
parentcd11ca9de3ea8d1c1efaabe0a7d9c4daea56a15b (diff)
downloadmeta-virtualization-227452ab4bb5b6518eb56def5a744ee9d4947cae.tar.gz
criu: cleanup; export USRBINPATH PEP517_INSTALL_PYTHON
Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--recipes-containers/criu/criu_git.bb8
1 files changed, 2 insertions, 6 deletions
diff --git a/recipes-containers/criu/criu_git.bb b/recipes-containers/criu/criu_git.bb
index b06fa636..b02de22e 100644
--- a/recipes-containers/criu/criu_git.bb
+++ b/recipes-containers/criu/criu_git.bb
@@ -75,18 +75,14 @@ do_compile:prepend() {
75} 75}
76 76
77do_compile () { 77do_compile () {
78 #python_pep517_do_compile
79 #export PEP517_SOURCE_PATH="${S}/crit"
80 #python_pep517_do_compile
81 #oe_runmake
82 #oe_runmake #PIP_BREAK_SYSTEM_PACKAGES=1
83 export PEP517_WHEEL_PATH="${PEP517_WHEEL_PATH}"
84 oe_runmake FULL_PYTHON=${PYTHON} PYTHON=nativepython3 78 oe_runmake FULL_PYTHON=${PYTHON} PYTHON=nativepython3
85} 79}
86 80
87do_install () { 81do_install () {
88 export INSTALL_LIB="${libdir}/${PYTHON_DIR}/site-packages" 82 export INSTALL_LIB="${libdir}/${PYTHON_DIR}/site-packages"
89 export PEP517_WHEEL_PATH="${PEP517_WHEEL_PATH}" 83 export PEP517_WHEEL_PATH="${PEP517_WHEEL_PATH}"
84 export USRBINPATH="${USRBINPATH}"
85 export PEP517_INSTALL_PYTHON="${PEP517_INSTALL_PYTHON}"
90 oe_runmake PREFIX=${exec_prefix} LIBDIR=${libdir} DESTDIR="${D}" PLUGINDIR="${localstatedir}/lib" FULL_PYTHON=${PYTHON} PYTHON=nativepython3 install 86 oe_runmake PREFIX=${exec_prefix} LIBDIR=${libdir} DESTDIR="${D}" PLUGINDIR="${localstatedir}/lib" FULL_PYTHON=${PYTHON} PYTHON=nativepython3 install
91 87
92 # python3's distutils has a feature of rewriting the interpeter on setup installed 88 # python3's distutils has a feature of rewriting the interpeter on setup installed