summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRalph Siemsen <ralph.siemsen@linaro.org>2021-04-28 11:44:09 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-04-29 23:09:47 -0400
commit1fcb4e75f8db633b1f684c7298dc07c6c00465f8 (patch)
tree790dd6f2a583d483761edba2f68191a34663376b
parent52eb86c17e98cd2fa0346ee98657906fde1d44e0 (diff)
downloadmeta-virtualization-1fcb4e75f8db633b1f684c7298dc07c6c00465f8.tar.gz
docker: add CVE_PRODUCT to recipes
Allows the yocto cve-checker to flag CVEs, which would otherwise go unreported due to the package name not matching NIST NVD data. Signed-off-by: Ralph Siemsen <ralph.siemsen@linaro.org> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/docker-distribution/docker-distribution_git.bb2
-rw-r--r--recipes-containers/docker/docker-ce_git.bb2
-rw-r--r--recipes-containers/docker/docker-moby.bb2
3 files changed, 6 insertions, 0 deletions
diff --git a/recipes-containers/docker-distribution/docker-distribution_git.bb b/recipes-containers/docker-distribution/docker-distribution_git.bb
index 4bf3c6e5..50d5a642 100644
--- a/recipes-containers/docker-distribution/docker-distribution_git.bb
+++ b/recipes-containers/docker-distribution/docker-distribution_git.bb
@@ -68,3 +68,5 @@ SYSTEMD_SERVICE_docker-registry = "${@bb.utils.contains('DISTRO_FEATURES','syste
68SYSTEMD_AUTO_ENABLE_docker-registry = "enable" 68SYSTEMD_AUTO_ENABLE_docker-registry = "enable"
69 69
70RDEPENDS_${PN}-ptest_remove = "${PN}" 70RDEPENDS_${PN}-ptest_remove = "${PN}"
71
72CVE_PRODUCT = "docker_registry"
diff --git a/recipes-containers/docker/docker-ce_git.bb b/recipes-containers/docker/docker-ce_git.bb
index 14182d12..adffcec6 100644
--- a/recipes-containers/docker/docker-ce_git.bb
+++ b/recipes-containers/docker/docker-ce_git.bb
@@ -129,3 +129,5 @@ FILES_${PN} += "${systemd_unitdir}/system/* ${sysconfdir}/docker"
129 129
130FILES_${PN}-contrib += "${datadir}/docker/check-config.sh" 130FILES_${PN}-contrib += "${datadir}/docker/check-config.sh"
131RDEPENDS_${PN}-contrib += "bash" 131RDEPENDS_${PN}-contrib += "bash"
132
133CVE_PRODUCT = "docker"
diff --git a/recipes-containers/docker/docker-moby.bb b/recipes-containers/docker/docker-moby.bb
index 762a785f..600603f1 100644
--- a/recipes-containers/docker/docker-moby.bb
+++ b/recipes-containers/docker/docker-moby.bb
@@ -148,3 +148,5 @@ FILES_${PN} += "${systemd_unitdir}/system/* ${sysconfdir}/docker"
148 148
149FILES_${PN}-contrib += "${datadir}/docker/check-config.sh" 149FILES_${PN}-contrib += "${datadir}/docker/check-config.sh"
150RDEPENDS_${PN}-contrib += "bash" 150RDEPENDS_${PN}-contrib += "bash"
151
152CVE_PRODUCT = "docker"