summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHe Zhe <zhe.he@windriver.com>2018-07-24 05:50:01 -0700
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-07-26 10:42:06 -0400
commit1e67a44db7ec87617455b3228ee5237ceb037173 (patch)
tree43114615a55b6898a1281d215c0ca7d71481565b
parenteeb10ba17cb33ba5200a7b9f100ae9e2ce6e951f (diff)
downloadmeta-virtualization-1e67a44db7ec87617455b3228ee5237ceb037173.tar.gz
libvirt: Remove unsupported configure options and fix warning
xen and xen-inotify have been removed from upstream. We change PACKAGECONFIG accordingly. pkg_postinst has been deprecated, use pkg_postinst_ontarget instead. WARNING: do_rootfs: Intentionally failing postinstall scriptlets of ['libvirt'] to defer them to first boot is deprecated. Please place them into pkg_postinst_ontarget_${PN} (). Signed-off-by: He Zhe <zhe.he@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-extended/libvirt/libvirt_4.3.0.bb6
1 files changed, 2 insertions, 4 deletions
diff --git a/recipes-extended/libvirt/libvirt_4.3.0.bb b/recipes-extended/libvirt/libvirt_4.3.0.bb
index edd52616..e6dac5d9 100644
--- a/recipes-extended/libvirt/libvirt_4.3.0.bb
+++ b/recipes-extended/libvirt/libvirt_4.3.0.bb
@@ -175,7 +175,7 @@ PRIVATE_LIBS_${PN}-ptest = " \
175PACKAGECONFIG ??= "qemu yajl uml openvz vmware vbox esx iproute2 lxc test \ 175PACKAGECONFIG ??= "qemu yajl uml openvz vmware vbox esx iproute2 lxc test \
176 remote macvtap libvirtd netcf udev python ebtables \ 176 remote macvtap libvirtd netcf udev python ebtables \
177 ${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux audit libcap-ng', '', d)} \ 177 ${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux audit libcap-ng', '', d)} \
178 ${@bb.utils.contains('DISTRO_FEATURES', 'xen', 'xen libxl xen-inotify', '', d)} \ 178 ${@bb.utils.contains('DISTRO_FEATURES', 'xen', 'libxl', '', d)} \
179 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'polkit', '', d)} \ 179 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'polkit', '', d)} \
180 " 180 "
181 181
@@ -183,10 +183,8 @@ PACKAGECONFIG ??= "qemu yajl uml openvz vmware vbox esx iproute2 lxc test \
183# 183#
184PACKAGECONFIG[qemu] = "--with-qemu,--without-qemu,qemu," 184PACKAGECONFIG[qemu] = "--with-qemu,--without-qemu,qemu,"
185PACKAGECONFIG[yajl] = "--with-yajl,--without-yajl,yajl,yajl" 185PACKAGECONFIG[yajl] = "--with-yajl,--without-yajl,yajl,yajl"
186PACKAGECONFIG[xen] = "--with-xen,--without-xen,xen,"
187PACKAGECONFIG[xenapi] = "--with-xenapi,--without-xenapi,," 186PACKAGECONFIG[xenapi] = "--with-xenapi,--without-xenapi,,"
188PACKAGECONFIG[libxl] = "--with-libxl=${STAGING_DIR_TARGET}/lib,--without-libxl,libxl," 187PACKAGECONFIG[libxl] = "--with-libxl=${STAGING_DIR_TARGET}/lib,--without-libxl,libxl,"
189PACKAGECONFIG[xen-inotify] = "--with-xen-inotify,--without-xen-inotify,xen,"
190PACKAGECONFIG[uml] = "--with-uml, --without-uml,," 188PACKAGECONFIG[uml] = "--with-uml, --without-uml,,"
191PACKAGECONFIG[openvz] = "--with-openvz,--without-openvz,," 189PACKAGECONFIG[openvz] = "--with-openvz,--without-openvz,,"
192PACKAGECONFIG[vmware] = "--with-vmware,--without-vmware,," 190PACKAGECONFIG[vmware] = "--with-vmware,--without-vmware,,"
@@ -305,7 +303,7 @@ do_install_ptest() {
305 done 303 done
306} 304}
307 305
308pkg_postinst_libvirt() { 306pkg_postinst_ontarget_${PN}() {
309 if [ -z "$D" ] && [ -e /etc/init.d/populate-volatile.sh ] ; then 307 if [ -z "$D" ] && [ -e /etc/init.d/populate-volatile.sh ] ; then
310 /etc/init.d/populate-volatile.sh update 308 /etc/init.d/populate-volatile.sh update
311 fi 309 fi