diff options
author | Amy Fong <amy.fong@windriver.com> | 2013-06-20 10:25:04 -0700 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2013-06-27 13:40:07 -0400 |
commit | 16811e532c0d38a4b0d3a4abcac4c25d8b3cc3f3 (patch) | |
tree | 4ec7608fd8353c4a6218d054d785437a05d8e579 | |
parent | 55884d203d1e7ca5c39561f5efdc1bf14034d854 (diff) | |
download | meta-virtualization-16811e532c0d38a4b0d3a4abcac4c25d8b3cc3f3.tar.gz |
Uprev irqbalance to 1.0.5
Uprev irqbalance to the latest version.
* consolidate logging
* Implement user policy script callout
(http://code.google.com/p/irqbalance/issues/detail?id=35)
* Replace fscanf(%as) by getline
* manpage: Improve the readability of the --banirq text
* glib-local: ad call for g_list_remove
Also splitting files into inc and bb files.
Signed-off-by: Amy Fong <amy.fong@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r-- | recipes-extended/irqbalance/irqbalance.inc | 32 | ||||
-rw-r--r-- | recipes-extended/irqbalance/irqbalance_1.0.4.bb | 37 | ||||
-rw-r--r-- | recipes-extended/irqbalance/irqbalance_1.0.5.bb | 14 |
3 files changed, 53 insertions, 30 deletions
diff --git a/recipes-extended/irqbalance/irqbalance.inc b/recipes-extended/irqbalance/irqbalance.inc new file mode 100644 index 00000000..c0769133 --- /dev/null +++ b/recipes-extended/irqbalance/irqbalance.inc | |||
@@ -0,0 +1,32 @@ | |||
1 | # | ||
2 | # Copyright (C) 2013 Wind River Systems, Inc. | ||
3 | # | ||
4 | SUMMARY = "IRQ allocation daemon" | ||
5 | DESCRIPTION = "A daemon to balance interrupts across multiple CPUs, \ | ||
6 | which can lead to better performance and IO balance on SMP systems." | ||
7 | |||
8 | HOMEPAGE = "http://code.google.com/p/irqbalance/" | ||
9 | BUGTRACKER = "http://code.google.com/p/irqbalance/issues/list" | ||
10 | |||
11 | LICENSE = "GPLv2" | ||
12 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ | ||
13 | file://irqbalance.c;beginline=6;endline=8;md5=b94e153694672307b503b1bc87dc9e24 \ | ||
14 | " | ||
15 | |||
16 | DEPENDS = "glib-2.0" | ||
17 | |||
18 | INITSCRIPT_NAME = "irqbalanced" | ||
19 | INITSCRIPT_PARAMS = "defaults" | ||
20 | |||
21 | inherit autotools | ||
22 | inherit update-rc.d | ||
23 | |||
24 | EXTRA_OECONF = "--program-transform-name= \ | ||
25 | " | ||
26 | |||
27 | do_install () { | ||
28 | oe_runmake 'DESTDIR=${D}' install | ||
29 | install -d ${D}${sysconfdir}/init.d | ||
30 | cat ${S}/irqbalance.init | sed -e's,/usr/sbin,${sbindir},g' > ${D}${sysconfdir}/init.d/irqbalanced | ||
31 | chmod 755 ${D}${sysconfdir}/init.d/irqbalanced | ||
32 | } | ||
diff --git a/recipes-extended/irqbalance/irqbalance_1.0.4.bb b/recipes-extended/irqbalance/irqbalance_1.0.4.bb index aa9941c5..33703f8b 100644 --- a/recipes-extended/irqbalance/irqbalance_1.0.4.bb +++ b/recipes-extended/irqbalance/irqbalance_1.0.4.bb | |||
@@ -1,39 +1,16 @@ | |||
1 | # | 1 | # |
2 | # Copyright (C) 2013 Wind River Systems, Inc. | 2 | # Copyright (C) 2013 Wind River Systems, Inc. |
3 | # | 3 | # |
4 | SUMMARY = "IRQ allocation daemon" | ||
5 | DESCRIPTION = "A daemon to balance interrupts across multiple CPUs, \ | ||
6 | which can lead to better performance and IO balance on SMP systems." | ||
7 | 4 | ||
8 | HOMEPAGE = "http://code.google.com/p/irqbalance/" | 5 | require irqbalance.inc |
9 | BUGTRACKER = "http://code.google.com/p/irqbalance/issues/list" | ||
10 | 6 | ||
11 | LICENSE = "GPLv2" | 7 | PR = "r1" |
12 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ | ||
13 | file://irqbalance.c;beginline=6;endline=8;md5=b94e153694672307b503b1bc87dc9e24 \ | ||
14 | " | ||
15 | |||
16 | DEPENDS = "glib-2.0" | ||
17 | SRC_URI = "http://irqbalance.googlecode.com/files/irqbalance-${PV}.tar.bz2 \ | ||
18 | file://add-initscript.patch \ | ||
19 | " | ||
20 | 8 | ||
21 | SRC_URI[md5sum] = "f7ca283c46331db73f27e686a643dcfb" | 9 | SRC_URI[md5sum] = "f7ca283c46331db73f27e686a643dcfb" |
22 | SRC_URI[sha256sum] = "15725edf4a6f20258620cbd05ebf02d0c25aadd5ffa4871ef8507c9215021c43" | 10 | SRC_URI[sha256su] = "15725edf4a6f20258620cbd05ebf02d0c25aadd5ffa4871ef8507c9215021c43" |
23 | |||
24 | INITSCRIPT_NAME = "irqbalanced" | ||
25 | INITSCRIPT_PARAMS = "defaults" | ||
26 | 11 | ||
27 | inherit autotools | 12 | EXTRA_OECONF += "--with-sysroot=${STAGING_DIR_TARGET}" |
28 | inherit update-rc.d | ||
29 | 13 | ||
30 | EXTRA_OECONF = "--program-transform-name= \ | 14 | SRC_URI = "http://irqbalance.googlecode.com/files/irqbalance-${PV}.tar.bz2 \ |
31 | --with-sysroot=${STAGING_DIR_TARGET} \ | 15 | file://add-initscript.patch \ |
32 | " | 16 | " |
33 | |||
34 | do_install () { | ||
35 | oe_runmake 'DESTDIR=${D}' install | ||
36 | install -d ${D}${sysconfdir}/init.d | ||
37 | cat ${S}/irqbalance.init | sed -e's,/usr/sbin,${sbindir},g' > ${D}${sysconfdir}/init.d/irqbalanced | ||
38 | chmod 755 ${D}${sysconfdir}/init.d/irqbalanced | ||
39 | } | ||
diff --git a/recipes-extended/irqbalance/irqbalance_1.0.5.bb b/recipes-extended/irqbalance/irqbalance_1.0.5.bb new file mode 100644 index 00000000..49c3acd1 --- /dev/null +++ b/recipes-extended/irqbalance/irqbalance_1.0.5.bb | |||
@@ -0,0 +1,14 @@ | |||
1 | # | ||
2 | # Copyright (C) 2013 Wind River Systems, Inc. | ||
3 | # | ||
4 | |||
5 | require irqbalance.inc | ||
6 | |||
7 | PR = "r0" | ||
8 | |||
9 | SRC_URI[md5sum] = "b6403fa067c96adce448a48c9993654d" | ||
10 | SRC_URI[sha256sum] = "1123e75224b9c0b63ac85892e920bc4a9c76211278ea3d5d4bcbbde44815685c" | ||
11 | |||
12 | SRC_URI = "http://irqbalance.googlecode.com/files/irqbalance-${PV}.tar.gz \ | ||
13 | file://add-initscript.patch \ | ||
14 | " | ||