summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongzhi.Song <hongzhi.song@windriver.com>2018-08-31 08:02:14 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-09-05 16:32:02 -0400
commit0dc10a5bf8b962e953440b66c6098afec35208ea (patch)
tree9a0f51c7e6177d7dc6a9754e82d853072fef9808
parenta352f4081b907e5db602104cfaed202284ddba6c (diff)
downloadmeta-virtualization-0dc10a5bf8b962e953440b66c6098afec35208ea.tar.gz
diod/ops.c: add header file for makedev
Error: diod/ops.c:845: undefined reference to `makedev' Fixed: Glibc removes sys/sysmacros.h which defines makedev from sys/types.h since v2.28. [Commit ID: e16deca62e16f] And then glibc suggestions us to include <sys/sysmacros.h> directly if code needs it. Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-extended/diod/diod_1.0.24.bb1
-rw-r--r--recipes-extended/diod/files/0001-diod-ops.c-add-header-file-for-makedev.patch40
2 files changed, 41 insertions, 0 deletions
diff --git a/recipes-extended/diod/diod_1.0.24.bb b/recipes-extended/diod/diod_1.0.24.bb
index a4d159ab..bb5707e5 100644
--- a/recipes-extended/diod/diod_1.0.24.bb
+++ b/recipes-extended/diod/diod_1.0.24.bb
@@ -15,6 +15,7 @@ SRC_URI = "git://github.com/chaos/diod.git;protocol=git \
15 file://diod.conf \ 15 file://diod.conf \
16 file://0001-build-allow-builds-to-work-with-separate-build-dir.patch \ 16 file://0001-build-allow-builds-to-work-with-separate-build-dir.patch \
17 file://0002-auto.diod.in-remove-bashisms.patch \ 17 file://0002-auto.diod.in-remove-bashisms.patch \
18 file://0001-diod-ops.c-add-header-file-for-makedev.patch \
18 " 19 "
19DEPENDS = "libcap ncurses tcp-wrappers lua" 20DEPENDS = "libcap ncurses tcp-wrappers lua"
20 21
diff --git a/recipes-extended/diod/files/0001-diod-ops.c-add-header-file-for-makedev.patch b/recipes-extended/diod/files/0001-diod-ops.c-add-header-file-for-makedev.patch
new file mode 100644
index 00000000..e6f7ece2
--- /dev/null
+++ b/recipes-extended/diod/files/0001-diod-ops.c-add-header-file-for-makedev.patch
@@ -0,0 +1,40 @@
1From f75836731d6051d85e6317eb4c12465bafb4973e Mon Sep 17 00:00:00 2001
2From: "Hongzhi.Song" <hongzhi.song@windriver.com>
3Date: Fri, 31 Aug 2018 05:47:02 -0400
4Subject: [PATCH] diod/ops.c: add header file for makedev
5
6Error:
7diod/ops.c:845: undefined reference to `makedev'
8
9Fixed:
10Glibc removes sys/sysmacros.h which defines makedev from sys/types.h
11since v2.28. [Commit ID: e16deca62e16f]
12
13And then glibc suggestions us to include <sys/sysmacros.h> directly if
14code needs it.
15
16Upstream-Status: Submitted
17[diod:
18mail: v9fs-developer@lists.sourceforge.net
19author: hongzhi.song@windriver.com]
20
21Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com>
22---
23 diod/ops.c | 1 +
24 1 file changed, 1 insertion(+)
25
26diff --git a/diod/ops.c b/diod/ops.c
27index c6c8291..469a502 100644
28--- a/diod/ops.c
29+++ b/diod/ops.c
30@@ -74,6 +74,7 @@
31 #include <pthread.h>
32 #include <errno.h>
33 #include <sys/types.h>
34+#include <sys/sysmacros.h>
35
36 #ifdef __FreeBSD__
37 #if !__BSD_VISIBLE
38--
392.8.1
40