summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukasz Czechowski <lukasz.czechowski@thaumatec.com>2024-04-17 00:56:15 +0200
committerBruce Ashfield <bruce.ashfield@gmail.com>2024-04-22 15:02:52 +0000
commit0b5cf637964a772f5547577dc288f1bd1b62ffc8 (patch)
treef7b72962f75fc4ef789d2ca8433074091bf97421
parentb7e77b69d309d8ee985720e88b19b6e9cf03fe63 (diff)
downloadmeta-virtualization-0b5cf637964a772f5547577dc288f1bd1b62ffc8.tar.gz
podman: fix location of user systemd service units
The value of USERSYSTEMDDIR is currently set to ${systemd_unitdir}/user, which might not be present in user unit search path. Use dedicated bitbake variable ${systemd_user_unitdir} instead. Signed-off-by: Lukasz Czechowski <lukasz.czechowski@thaumatec.com> Cc: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/podman/podman_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-containers/podman/podman_git.bb b/recipes-containers/podman/podman_git.bb
index 3eadd202..f69dec16 100644
--- a/recipes-containers/podman/podman_git.bb
+++ b/recipes-containers/podman/podman_git.bb
@@ -62,7 +62,7 @@ do_configure[noexec] = "1"
62EXTRA_OEMAKE = " \ 62EXTRA_OEMAKE = " \
63 PREFIX=${prefix} BINDIR=${bindir} LIBEXECDIR=${libexecdir} \ 63 PREFIX=${prefix} BINDIR=${bindir} LIBEXECDIR=${libexecdir} \
64 ETCDIR=${sysconfdir} TMPFILESDIR=${nonarch_libdir}/tmpfiles.d \ 64 ETCDIR=${sysconfdir} TMPFILESDIR=${nonarch_libdir}/tmpfiles.d \
65 SYSTEMDDIR=${systemd_unitdir}/system USERSYSTEMDDIR=${systemd_unitdir}/user \ 65 SYSTEMDDIR=${systemd_unitdir}/system USERSYSTEMDDIR=${systemd_user_unitdir} \
66" 66"
67 67
68# remove 'docker' from the packageconfig if you don't want podman to 68# remove 'docker' from the packageconfig if you don't want podman to
@@ -134,7 +134,7 @@ do_install_ptest () {
134FILES:${PN} += " \ 134FILES:${PN} += " \
135 ${systemd_unitdir}/system/* \ 135 ${systemd_unitdir}/system/* \
136 ${nonarch_libdir}/systemd/* \ 136 ${nonarch_libdir}/systemd/* \
137 ${systemd_unitdir}/user/* \ 137 ${systemd_user_unitdir/* \
138 ${nonarch_libdir}/tmpfiles.d/* \ 138 ${nonarch_libdir}/tmpfiles.d/* \
139 ${datadir}/user-tmpfiles.d/* \ 139 ${datadir}/user-tmpfiles.d/* \
140 ${sysconfdir}/cni \ 140 ${sysconfdir}/cni \