summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Wessel <jason.wessel@windriver.com>2018-09-05 15:44:45 -0700
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-09-06 12:45:14 -0400
commit09b67e49bf871fd1988d1d567626a4382ebc2fb0 (patch)
tree3cc8b4844ae47739ce0f1edb5f6da3eafdf5e3bf
parent4e02acfb79636d49a46890899aa034b936d01416 (diff)
downloadmeta-virtualization-09b67e49bf871fd1988d1d567626a4382ebc2fb0.tar.gz
openvswitch: Turn off ssl integration by default
The openssl library is an optional component for the openvswitch. The problem with it enabled by default is that it will consume system entropy to try to initialize the openssl library even though we are not using it by default. With the 4.16 kernel and up there is not always enough entropy available at the early boot time which can cause a lengthy stall, while waiting to initialize the openvswitch. If ssl is needed, it can of course be turned on with the package config option "ssl". Signed-off-by: Jason Wessel <jason.wessel@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-networking/openvswitch/openvswitch_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-networking/openvswitch/openvswitch_git.bb b/recipes-networking/openvswitch/openvswitch_git.bb
index 4a6002a9..4cd82d77 100644
--- a/recipes-networking/openvswitch/openvswitch_git.bb
+++ b/recipes-networking/openvswitch/openvswitch_git.bb
@@ -40,6 +40,7 @@ DPDK_INSTALL_DIR ?= "/opt/dpdk"
40PACKAGECONFIG ?= "libcap-ng" 40PACKAGECONFIG ?= "libcap-ng"
41PACKAGECONFIG[dpdk] = "--with-dpdk=${STAGING_DIR_TARGET}${DPDK_INSTALL_DIR}/share/${TARGET_ARCH}-native-linuxapp-gcc,,dpdk,dpdk" 41PACKAGECONFIG[dpdk] = "--with-dpdk=${STAGING_DIR_TARGET}${DPDK_INSTALL_DIR}/share/${TARGET_ARCH}-native-linuxapp-gcc,,dpdk,dpdk"
42PACKAGECONFIG[libcap-ng] = "--enable-libcapng,--disable-libcapng,libcap-ng," 42PACKAGECONFIG[libcap-ng] = "--enable-libcapng,--disable-libcapng,libcap-ng,"
43PACKAGECONFIG[ssl] = ",--disable-ssl,openssl,"
43 44
44# Don't compile kernel modules by default since it heavily depends on 45# Don't compile kernel modules by default since it heavily depends on
45# kernel version. Use the in-kernel module for now. 46# kernel version. Use the in-kernel module for now.