summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMing Liu <liu.ming50@gmail.com>2019-12-07 14:21:28 +0100
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-12-10 02:09:40 -0500
commit06ec74ad35999fb87b2be950ead67815d59fbf63 (patch)
tree3e2316e5300ac64edc78dd8acf0d9a00bdd7dfde
parent6dd323eb4a68dceeeef012dae9cc55c4fb218a04 (diff)
downloadmeta-virtualization-06ec74ad35999fb87b2be950ead67815d59fbf63.tar.gz
python3-nacl: add 1.3.0 recipe
A regression was introduced by commit ab12e48a: [ python3-docker-compose: uprev to 1.25.0 ] python3-docker-compose depends on python3-paramiko hence also depends on python3-nacl but that recipe does not exist. Port it from meta-lmp layer. Signed-off-by: Ming Liu <liu.ming50@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-devtools/python/python3-nacl_1.3.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-nacl_1.3.0.bb b/recipes-devtools/python/python3-nacl_1.3.0.bb
new file mode 100644
index 00000000..d0a99aef
--- /dev/null
+++ b/recipes-devtools/python/python3-nacl_1.3.0.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Python binding to the Networking and Cryptography (NaCl) library"
2HOMEPAGE = "https://github.com/pyca/pynacl"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=8cc789b082b3d97e1ccc5261f8594d3f"
5
6PYPI_PACKAGE = "PyNaCl"
7
8inherit pypi setuptools3
9
10SRC_URI[md5sum] = "3f3b1272287bc2de8efd8a5fa18bf728"
11SRC_URI[sha256sum] = "0c6100edd16fefd1557da078c7a31e7b7d7a52ce39fdca2bec29d4f7b6e7600c"
12
13DEPENDS += "\
14 libsodium \
15 python3-cffi-native \
16 python3-pip-native \
17"
18
19RDEPENDS_${PN}_class-target += " \
20 python3-cffi \
21 python3-pycparser \
22"
23
24export SODIUM_INSTALL = "system"
25
26BBCLASSEXTEND = "native"