summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-04-20 07:34:56 -0700
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-04-23 12:38:50 -0400
commit032ef5310419563a01baad0b1b94e4587d12f777 (patch)
treec656a37aa4cec124b006e1b2f584af9b1dee7da1
parentd4182f50f19d183630e0f908ff953c4f9402cabe (diff)
downloadmeta-virtualization-032ef5310419563a01baad0b1b94e4587d12f777.tar.gz
refactor for YP Compat for PV changes
Only include our versions of recipes if virtualiztions is in DISTRO_FEATURE Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--conf/distro/include/meta-virt-default-versions.inc9
-rw-r--r--conf/layer.conf2
-rw-r--r--recipes-devtools/python/python-blinker_1.3.bb2
-rw-r--r--recipes-devtools/python/python-gevent_1.0.1.bb4
-rw-r--r--recipes-devtools/python/python-m2crypto_0.22.3.bb2
-rw-r--r--recipes-devtools/python/python-pyyaml_3.11.bb2
-rw-r--r--recipes-devtools/python/python-redis_2.10.3.bb2
-rw-r--r--recipes-devtools/python/python-sqlalchemy_1.1.5.bb2
-rw-r--r--recipes-devtools/python/python-werkzeug_0.10.4.bb2
9 files changed, 26 insertions, 1 deletions
diff --git a/conf/distro/include/meta-virt-default-versions.inc b/conf/distro/include/meta-virt-default-versions.inc
new file mode 100644
index 00000000..27e7b90d
--- /dev/null
+++ b/conf/distro/include/meta-virt-default-versions.inc
@@ -0,0 +1,9 @@
1# Meta-virtuailization PREFERED_VERSION
2
3PREFERRED_VERSION_python-blinker = "1.3"
4PREFERRED_VERSION_python-gevent = "1.0.1"
5PREFERRED_VERSION_python-m2crypto = "0.22.3"
6PREFERRED_VERSION_python-pyyaml = "3.11"
7PREFERRED_VERSION_python-redis = "2.10.3"
8PREFERRED_VERSION_python-sqlalchemy = "1.1.5"
9PREFERRED_VERSION_python-werkzeug = "0.10.4"
diff --git a/conf/layer.conf b/conf/layer.conf
index 4233d39e..fa2e015e 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -26,3 +26,5 @@ PREFERRED_PROVIDER_virtual/containerd ?= "containerd-opencontainers"
26# Sanity check for meta-virtualization layer. 26# Sanity check for meta-virtualization layer.
27# Setting SKIP_META_VIRT_SANITY_CHECK to "1" would skip the bbappend files check. 27# Setting SKIP_META_VIRT_SANITY_CHECK to "1" would skip the bbappend files check.
28INHERIT += "sanity-meta-virt" 28INHERIT += "sanity-meta-virt"
29
30require ${@bb.utils.contains('DISTRO_FEATURES', 'virtualization', 'meta-virt-default-versions.inc', '', d)}
diff --git a/recipes-devtools/python/python-blinker_1.3.bb b/recipes-devtools/python/python-blinker_1.3.bb
index 24e19b50..8abb9c07 100644
--- a/recipes-devtools/python/python-blinker_1.3.bb
+++ b/recipes-devtools/python/python-blinker_1.3.bb
@@ -18,5 +18,7 @@ SRC_URI[sha256sum] = "6811010809262261e41ab7b92f3f6d23f35cf816fbec2bc05077992eeb
18 18
19S = "${WORKDIR}/${SRCNAME}-${PV}" 19S = "${WORKDIR}/${SRCNAME}-${PV}"
20 20
21DEFAULT_PREFERENCE = "-1"
22
21inherit setuptools 23inherit setuptools
22 24
diff --git a/recipes-devtools/python/python-gevent_1.0.1.bb b/recipes-devtools/python/python-gevent_1.0.1.bb
index 7f1d2622..8cd1388a 100644
--- a/recipes-devtools/python/python-gevent_1.0.1.bb
+++ b/recipes-devtools/python/python-gevent_1.0.1.bb
@@ -25,4 +25,6 @@ SRC_URI += "file://gevent-allow-ssl-v2-or-v3-certificates.patch"
25# so always force a cross compile 25# so always force a cross compile
26do_configure_append() { 26do_configure_append() {
27 sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/libev/configure 27 sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/libev/configure
28} \ No newline at end of file 28}
29
30DEFAULT_PREFERENCE = "-1"
diff --git a/recipes-devtools/python/python-m2crypto_0.22.3.bb b/recipes-devtools/python/python-m2crypto_0.22.3.bb
index 2c2625d3..e151dcc4 100644
--- a/recipes-devtools/python/python-m2crypto_0.22.3.bb
+++ b/recipes-devtools/python/python-m2crypto_0.22.3.bb
@@ -22,6 +22,8 @@ SRC_URI += " \
22SRC_URI[md5sum] = "573f21aaac7d5c9549798e72ffcefedd" 22SRC_URI[md5sum] = "573f21aaac7d5c9549798e72ffcefedd"
23SRC_URI[sha256sum] = "6071bfc817d94723e9b458a010d565365104f84aa73f7fe11919871f7562ff72" 23SRC_URI[sha256sum] = "6071bfc817d94723e9b458a010d565365104f84aa73f7fe11919871f7562ff72"
24 24
25DEFAULT_PREFERENCE = "-1"
26
25inherit setuptools pypi 27inherit setuptools pypi
26 28
27DEPENDS += "openssl swig-native" 29DEPENDS += "openssl swig-native"
diff --git a/recipes-devtools/python/python-pyyaml_3.11.bb b/recipes-devtools/python/python-pyyaml_3.11.bb
index cb1db8c6..ecb1719a 100644
--- a/recipes-devtools/python/python-pyyaml_3.11.bb
+++ b/recipes-devtools/python/python-pyyaml_3.11.bb
@@ -25,6 +25,8 @@ SRC_URI[sha256sum] = "c36c938a872e5ff494938b33b14aaa156cb439ec67548fcab3535bb78b
25 25
26S = "${WORKDIR}/${SRCNAME}-${PV}" 26S = "${WORKDIR}/${SRCNAME}-${PV}"
27 27
28DEFAULT_PREFERENCE = "-1"
29
28inherit setuptools 30inherit setuptools
29 31
30DEPENDS += "libyaml python-cython-native" 32DEPENDS += "libyaml python-cython-native"
diff --git a/recipes-devtools/python/python-redis_2.10.3.bb b/recipes-devtools/python/python-redis_2.10.3.bb
index 9eda8a5c..2ef2b6b7 100644
--- a/recipes-devtools/python/python-redis_2.10.3.bb
+++ b/recipes-devtools/python/python-redis_2.10.3.bb
@@ -15,6 +15,8 @@ SRC_URI[sha256sum] = "a4fb37b02860f6b1617f6469487471fd086dd2d38bbce640c2055862b9
15 15
16S = "${WORKDIR}/${SRCNAME}-${PV}" 16S = "${WORKDIR}/${SRCNAME}-${PV}"
17 17
18DEFAULT_PREFERENCE = "-1"
19
18inherit setuptools 20inherit setuptools
19 21
20RDEPENDS_${PN} = "redis" 22RDEPENDS_${PN} = "redis"
diff --git a/recipes-devtools/python/python-sqlalchemy_1.1.5.bb b/recipes-devtools/python/python-sqlalchemy_1.1.5.bb
index 63caeb48..f22d2728 100644
--- a/recipes-devtools/python/python-sqlalchemy_1.1.5.bb
+++ b/recipes-devtools/python/python-sqlalchemy_1.1.5.bb
@@ -13,4 +13,6 @@ SRC_URI[sha256sum] = "68fb40049690e567ebda7b270176f5abf0d53d9fbd515fec4e43326f60
13 13
14S = "${WORKDIR}/${SRCNAME}-${PV}" 14S = "${WORKDIR}/${SRCNAME}-${PV}"
15 15
16DEFAULT_PREFERENCE = "-1"
17
16inherit setuptools 18inherit setuptools
diff --git a/recipes-devtools/python/python-werkzeug_0.10.4.bb b/recipes-devtools/python/python-werkzeug_0.10.4.bb
index 763e5b98..5f3e01fd 100644
--- a/recipes-devtools/python/python-werkzeug_0.10.4.bb
+++ b/recipes-devtools/python/python-werkzeug_0.10.4.bb
@@ -14,6 +14,8 @@ SRC_URI[sha256sum] = "9d2771e4c89be127bc4bac056ab7ceaf0e0064c723d6b6e195739c3af4
14 14
15S = "${WORKDIR}/${SRCNAME}-${PV}" 15S = "${WORKDIR}/${SRCNAME}-${PV}"
16 16
17DEFAULT_PREFERENCE = "-1"
18
17inherit setuptools 19inherit setuptools
18 20
19RDEPENDS_${PN} += "python-io \ 21RDEPENDS_${PN} += "python-io \