summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2023-10-26 19:43:49 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2023-10-27 03:21:17 +0000
commitb8db7002764712f2902fe9dea098c171b1128076 (patch)
treedecf6830c78b69c8cc8014e2a9fa37a09e7602e1
parentf7b729d44df5916973e56319907e59a9d8961a6b (diff)
downloadmeta-virtualization-mickledore.tar.gz
cni: clean dir ${B}/plugins before do_compilemickledore
Clean dir ${B}/plugins before do_compile to avoid cni generated binaries like /usr/libexec/cni/bridge has wrong dynamic linker path and reports error like: /usr/libexec/cni/bridge: no such file or directory". Reproduce steps: 1. bitbake cni 2. enable usrmerge feature in local.conf 3. bitbake cni After step 2, GOBUILDFLAGS changed, "-I /lib64/ld-linux-aarch64.so.1" -> "/usr/lib/ld-linux-aarch64.so.1" But "go build" seems only check if the cached packagefile changed, since all not changed, the dynamic linker still use the old one, maybe go build should improve this. Clean dir ${B}/plugins to trigger rebuild of the binaries here. Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-networking/cni/cni_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-networking/cni/cni_git.bb b/recipes-networking/cni/cni_git.bb
index 06cef81f..38f15ea2 100644
--- a/recipes-networking/cni/cni_git.bb
+++ b/recipes-networking/cni/cni_git.bb
@@ -53,6 +53,8 @@ do_compile() {
53 done 53 done
54} 54}
55 55
56do_compile[cleandirs] = "${B}/plugins"
57
56do_install() { 58do_install() {
57 localbindir="${libexecdir}/cni/" 59 localbindir="${libexecdir}/cni/"
58 60