summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Oberhuber <mober.at@gmail.com>2018-01-23 22:44:00 +0100
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-01-29 10:16:11 -0500
commit3830a671507b6cf935115ab06b576474388b44a2 (patch)
tree17d0b21ea200abde10426e5c49757908163f8799
parent042425c1d98bdd7e44a62789bd03b375045266f5 (diff)
downloadmeta-virtualization-jethro.tar.gz
Fix docker-registry downloads by using https://pypi.python.orgjethro
The docker-registry recipe depends on a couple of Python packages which use a SRC_URI with http:// protocol. In jethro, this leads to an error message "ERROR 403: SSL is required" when building. In jethro, the issue is fixed by converting affected http:// URIs to https. Note that morty or later do not show the build error although they use http. Signed-off-by: Martin Oberhuber <mober.at@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-devtools/python/python-gevent_1.0.1.bb4
-rw-r--r--recipes-devtools/python/python-m2crypto_0.22.3.bb2
-rw-r--r--recipes-devtools/python/python-requests_2.3.0.bb2
-rw-r--r--recipes-devtools/python/python-sphinx_1.3.1.bb2
-rw-r--r--recipes-devtools/python/python-webob_1.4.1.bb2
5 files changed, 6 insertions, 6 deletions
diff --git a/recipes-devtools/python/python-gevent_1.0.1.bb b/recipes-devtools/python/python-gevent_1.0.1.bb
index 47f1267a..f7064237 100644
--- a/recipes-devtools/python/python-gevent_1.0.1.bb
+++ b/recipes-devtools/python/python-gevent_1.0.1.bb
@@ -13,7 +13,7 @@ RDEPENDS_${PN} += "python-greenlet python-mime python-pprint python-re"
13 13
14SRCNAME = "gevent" 14SRCNAME = "gevent"
15 15
16SRC_URI = "http://pypi.python.org/packages/source/g/gevent/${SRCNAME}-${PV}.tar.gz" 16SRC_URI = "https://pypi.python.org/packages/source/g/gevent/${SRCNAME}-${PV}.tar.gz"
17SRC_URI[md5sum] = "7b952591d1a0174d6eb6ac47bd975ab6" 17SRC_URI[md5sum] = "7b952591d1a0174d6eb6ac47bd975ab6"
18SRC_URI[sha256sum] = "4627e215d058f71d95e6b26d9e7be4c263788a4756bd2858a93775f6c072df43" 18SRC_URI[sha256sum] = "4627e215d058f71d95e6b26d9e7be4c263788a4756bd2858a93775f6c072df43"
19 19
@@ -30,4 +30,4 @@ SRC_URI += "file://gevent-allow-ssl-v2-or-v3-certificates.patch"
30# so always force a cross compile 30# so always force a cross compile
31do_configure_append() { 31do_configure_append() {
32 sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/libev/configure 32 sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/libev/configure
33} \ No newline at end of file 33}
diff --git a/recipes-devtools/python/python-m2crypto_0.22.3.bb b/recipes-devtools/python/python-m2crypto_0.22.3.bb
index 33254552..c5d4fe6f 100644
--- a/recipes-devtools/python/python-m2crypto_0.22.3.bb
+++ b/recipes-devtools/python/python-m2crypto_0.22.3.bb
@@ -14,7 +14,7 @@ LICENSE = "BSD"
14LIC_FILES_CHKSUM = "file://PKG-INFO;md5=0ccca7097c1d29fa42e75e9c15c6ff2e" 14LIC_FILES_CHKSUM = "file://PKG-INFO;md5=0ccca7097c1d29fa42e75e9c15c6ff2e"
15 15
16SRCNAME = "M2Crypto" 16SRCNAME = "M2Crypto"
17SRC_URI = "http://pypi.python.org/packages/source/M/M2Crypto/${SRCNAME}-${PV}.tar.gz" 17SRC_URI = "https://pypi.python.org/packages/source/M/M2Crypto/${SRCNAME}-${PV}.tar.gz"
18 18
19SRC_URI[md5sum] = "573f21aaac7d5c9549798e72ffcefedd" 19SRC_URI[md5sum] = "573f21aaac7d5c9549798e72ffcefedd"
20SRC_URI[sha256sum] = "6071bfc817d94723e9b458a010d565365104f84aa73f7fe11919871f7562ff72" 20SRC_URI[sha256sum] = "6071bfc817d94723e9b458a010d565365104f84aa73f7fe11919871f7562ff72"
diff --git a/recipes-devtools/python/python-requests_2.3.0.bb b/recipes-devtools/python/python-requests_2.3.0.bb
index 6f38bf1c..36392283 100644
--- a/recipes-devtools/python/python-requests_2.3.0.bb
+++ b/recipes-devtools/python/python-requests_2.3.0.bb
@@ -19,7 +19,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c7869e52c8275537186de35e3cd5f9ec"
19PR = "r0" 19PR = "r0"
20SRCNAME = "requests" 20SRCNAME = "requests"
21 21
22SRC_URI = "http://pypi.python.org/packages/source/r/requests/${SRCNAME}-${PV}.tar.gz" 22SRC_URI = "https://pypi.python.org/packages/source/r/requests/${SRCNAME}-${PV}.tar.gz"
23 23
24SRC_URI[md5sum] = "7449ffdc8ec9ac37bbcd286003c80f00" 24SRC_URI[md5sum] = "7449ffdc8ec9ac37bbcd286003c80f00"
25SRC_URI[sha256sum] = "1c1473875d846fe563d70868acf05b1953a4472f4695b7b3566d1d978957b8fc" 25SRC_URI[sha256sum] = "1c1473875d846fe563d70868acf05b1953a4472f4695b7b3566d1d978957b8fc"
diff --git a/recipes-devtools/python/python-sphinx_1.3.1.bb b/recipes-devtools/python/python-sphinx_1.3.1.bb
index fe8ad94a..d8cef309 100644
--- a/recipes-devtools/python/python-sphinx_1.3.1.bb
+++ b/recipes-devtools/python/python-sphinx_1.3.1.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=6dd095eaa1e7a662b279daf80ecad7e6"
7PR = "r0" 7PR = "r0"
8SRCNAME = "Sphinx" 8SRCNAME = "Sphinx"
9 9
10SRC_URI = "http://pypi.python.org/packages/source/S/${SRCNAME}/${SRCNAME}-${PV}.tar.gz" 10SRC_URI = "https://pypi.python.org/packages/source/S/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11 11
12SRC_URI[md5sum] = "8786a194acf9673464c5455b11fd4332" 12SRC_URI[md5sum] = "8786a194acf9673464c5455b11fd4332"
13SRC_URI[sha256sum] = "1a6e5130c2b42d2de301693c299f78cc4bd3501e78b610c08e45efc70e2b5114" 13SRC_URI[sha256sum] = "1a6e5130c2b42d2de301693c299f78cc4bd3501e78b610c08e45efc70e2b5114"
diff --git a/recipes-devtools/python/python-webob_1.4.1.bb b/recipes-devtools/python/python-webob_1.4.1.bb
index 18b38066..e5663637 100644
--- a/recipes-devtools/python/python-webob_1.4.1.bb
+++ b/recipes-devtools/python/python-webob_1.4.1.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://docs/license.txt;md5=8ed3584bcc78c16da363747ccabc5af5
7PR = "r0" 7PR = "r0"
8SRCNAME = "WebOb" 8SRCNAME = "WebOb"
9 9
10SRC_URI = "http://pypi.python.org/packages/source/W/${SRCNAME}/${SRCNAME}-${PV}.tar.gz" 10SRC_URI = "https://pypi.python.org/packages/source/W/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11 11
12SRC_URI[md5sum] = "a5c6e8ba5431756e6a5d5ec56047ec94" 12SRC_URI[md5sum] = "a5c6e8ba5431756e6a5d5ec56047ec94"
13SRC_URI[sha256sum] = "12f8b98390befc47336d2c0e5bad9cc48609d808eabb3f8675dc1027a3a9e9db" 13SRC_URI[sha256sum] = "12f8b98390befc47336d2c0e5bad9cc48609d808eabb3f8675dc1027a3a9e9db"