summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-10-18 13:27:28 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-10-18 13:51:56 -0400
commit92c5e5ef61b974b9fc84d407d1b02d7a5981f112 (patch)
treeabcab8000925541dc8191f325766c85f05ccdaa7
parent16e38ec8d0f390d3a5e8ee89fe74246edba0bd7c (diff)
downloadmeta-virtualization-honister-net.tar.gz
crun: fix offline buildshonister-net
The 'autogen.sh' script of crun was fetching dependencies that we already have in our SRC_URI. We want the OE git fetcher to manage the source, not scripts in the source of a package. We grab the two lines out of autogen.sh that we need, and use them directly in the configure_prepend. We also add yajl to the source code dependencies as the package DEPENDS is not enough as crun is explicitly building source that looks for the yajl code. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/crun/crun_git.bb13
1 files changed, 9 insertions, 4 deletions
diff --git a/recipes-containers/crun/crun_git.bb b/recipes-containers/crun/crun_git.bb
index dbc5c023..3243d4be 100644
--- a/recipes-containers/crun/crun_git.bb
+++ b/recipes-containers/crun/crun_git.bb
@@ -4,15 +4,17 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4PRIORITY = "optional" 4PRIORITY = "optional"
5 5
6SRCREV_crun = "360f5d02c37d5f7a67d38622010228ae2eeb80f1" 6SRCREV_crun = "360f5d02c37d5f7a67d38622010228ae2eeb80f1"
7SRCREV_libocispec = "c9b8b9524814550a489aa6d38b2dec95633ffa15" 7SRCREV_libocispec = "fb3c221d5849de9184f88b6929ce4a8c8fb55be9"
8SRCREV_ispec = "79b036d80240ae530a8de15e1d21c7ab9292c693" 8SRCREV_ispec = "54a822e528b91c8db63b873ad56daf200a2e5e61"
9SRCREV_rspec = "7413a7f753e1bd9a6a9c6dc7f96f55888cbbd476" 9SRCREV_rspec = "ab23082b188344f6fbb63a441ea00ffc2852d06d"
10SRCREV_yajl = "f344d21280c3e4094919fd318bc5ce75da91fc06"
10 11
11SRCREV_FORMAT = "crun_rspec" 12SRCREV_FORMAT = "crun_rspec"
12SRC_URI = "git://github.com/containers/crun.git;branch=main;name=crun \ 13SRC_URI = "git://github.com/containers/crun.git;branch=main;name=crun \
13 git://github.com/containers/libocispec.git;branch=main;name=libocispec;destsuffix=git/libocispec \ 14 git://github.com/containers/libocispec.git;branch=main;name=libocispec;destsuffix=git/libocispec \
14 git://github.com/opencontainers/runtime-spec.git;branch=master;name=rspec;destsuffix=git/libocispec/runtime-spec \ 15 git://github.com/opencontainers/runtime-spec.git;branch=master;name=rspec;destsuffix=git/libocispec/runtime-spec \
15 git://github.com/opencontainers/image-spec.git;branch=main;name=ispec;destsuffix=git/libocispec/image-spec \ 16 git://github.com/opencontainers/image-spec.git;branch=main;name=ispec;destsuffix=git/libocispec/image-spec \
17 git://github.com/containers/yajl.git;branch=main;name=yajl;destsuffix=git/libocispec/yajl \
16 " 18 "
17 19
18PV = "0.18+git${SRCREV_crun}" 20PV = "0.18+git${SRCREV_crun}"
@@ -34,7 +36,10 @@ DEPENDS += "systemd"
34DEPENDS += "oci-image-spec oci-runtime-spec" 36DEPENDS += "oci-image-spec oci-runtime-spec"
35 37
36do_configure:prepend () { 38do_configure:prepend () {
37 ./autogen.sh 39 # extracted from autogen.sh in crun source. This avoids
40 # git submodule fetching.
41 mkdir -p m4
42 autoreconf -fi
38} 43}
39 44
40do_install() { 45do_install() {