summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-11-06 12:21:04 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-11-06 12:47:19 -0400
commitb64de1f188e6f675cadf02c77bc72b06ed728eeb (patch)
treec2df0246f3814d91dc1a7ac632708013febe62ea
parent3fea81e4c58f7c0f263341a96eec2cca39e87a59 (diff)
downloadmeta-virtualization-easyjson.tar.gz
easyjson: -native recipe, statically linkedeasyjson
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-devtools/go/easyjson_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-devtools/go/easyjson_git.bb b/recipes-devtools/go/easyjson_git.bb
new file mode 100644
index 00000000..ef927087
--- /dev/null
+++ b/recipes-devtools/go/easyjson_git.bb
@@ -0,0 +1,27 @@
1SUMMARY = "easyjson"
2DESCRIPTION = "easy json command util"
3HOMEPAGE = "https://github.com/mailru/easyjson"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=819e81c2ec13e1bbc47dc5e90bb4d88b"
6
7RDEPENDS_${PN}-dev += "bash"
8
9SRC_URI = "git://${GO_IMPORT};nobranch=1;protocol=https"
10SRCREV = "11c9d7f52fd019df40f13aeecd28f11d941be9e3"
11PV="v0.7.7+git${SRCPV}"
12
13GO_IMPORT = "github.com/mailru/easyjson"
14GO_WORKDIR ?= "${GO_IMPORT}/easyjson"
15
16GO_LINKSHARED = ""
17export CGO_ENABLED = "1"
18
19inherit go-mod
20
21BBCLASSEXTEND = "native"
22
23GO_EXTLDFLAGS = "-static"
24# Upstream class "forgot" this argument
25#GOBUILDFLAGS:append = " -trimpath"
26
27INSANE_SKIP = "arch"