summaryrefslogtreecommitdiffstats
path: root/recipes-sota/sota-tools/sota-tools_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-sota/sota-tools/sota-tools_git.bb')
-rw-r--r--recipes-sota/sota-tools/sota-tools_git.bb24
1 files changed, 0 insertions, 24 deletions
diff --git a/recipes-sota/sota-tools/sota-tools_git.bb b/recipes-sota/sota-tools/sota-tools_git.bb
deleted file mode 100644
index 5403d9a..0000000
--- a/recipes-sota/sota-tools/sota-tools_git.bb
+++ /dev/null
@@ -1,24 +0,0 @@
1DESCRIPTION = "Utility to push data to a server"
2LICENSE = "MPL-2.0"
3
4LIC_FILES_CHKSUM = "file://LICENSE;md5=65d26fcc2f35ea6a181ac777e42db1ea"
5
6S = "${WORKDIR}/git"
7
8SRC_URI = "gitsm://github.com/advancedtelematic/sota-tools.git;branch=master"
9SRCREV = "216cb84db98e9b0f8c6c1c407f480c5dd0b3cf62"
10
11inherit cmake
12
13DEPENDS = "boost glib-2.0 curl libarchive"
14
15BBCLASSEXTEND = "native"
16
17FILES_${PN} = "${bindir}/garage-push"
18
19EXTRA_OECMAKE = "-DWARNING_AS_ERROR=OFF"
20
21do_install() {
22 install -d ${D}/${bindir}
23 install -m 755 garage-push ${D}/${bindir}
24}