summaryrefslogtreecommitdiffstats
path: root/recipes-sota/aktualizr/aktualizr_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-sota/aktualizr/aktualizr_git.bb')
-rw-r--r--recipes-sota/aktualizr/aktualizr_git.bb38
1 files changed, 19 insertions, 19 deletions
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb
index ecfbd2b..47e733c 100644
--- a/recipes-sota/aktualizr/aktualizr_git.bb
+++ b/recipes-sota/aktualizr/aktualizr_git.bb
@@ -6,12 +6,12 @@ LICENSE = "MPL-2.0"
6LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=815ca599c9df247a0c7f619bab123dad" 6LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=815ca599c9df247a0c7f619bab123dad"
7 7
8DEPENDS = "boost curl openssl libarchive libsodium sqlite3 asn1c-native" 8DEPENDS = "boost curl openssl libarchive libsodium sqlite3 asn1c-native"
9DEPENDS_append = "${@bb.utils.contains('PTEST_ENABLED', '1', ' coreutils-native net-tools-native ostree-native aktualizr-native ', '', d)}" 9DEPENDS:append = "${@bb.utils.contains('PTEST_ENABLED', '1', ' coreutils-native net-tools-native ostree-native aktualizr-native ', '', d)}"
10RDEPENDS_${PN}_class-target = "${PN}-hwid lshw" 10RDEPENDS:${PN}:class-target = "${PN}-hwid lshw"
11 11
12RDEPENDS_${PN}-ptest += "bash cmake curl net-tools python3-core python3-misc python3-modules openssl-bin sqlite3 valgrind" 12RDEPENDS:${PN}-ptest += "bash cmake curl net-tools python3-core python3-misc python3-modules openssl-bin sqlite3 valgrind"
13 13
14PRIVATE_LIBS_${PN}-ptest = "libaktualizr.so libaktualizr_secondary.so" 14PRIVATE_LIBS:${PN}-ptest = "libaktualizr.so libaktualizr_secondary.so"
15 15
16PV = "1.0+git${SRCPV}" 16PV = "1.0+git${SRCPV}"
17PR = "7" 17PR = "7"
@@ -39,12 +39,12 @@ S = "${WORKDIR}/git"
39inherit cmake pkgconfig ptest systemd 39inherit cmake pkgconfig ptest systemd
40 40
41# disable ptest by default as it slows down builds quite a lot 41# disable ptest by default as it slows down builds quite a lot
42# can be enabled manually by setting 'PTEST_ENABLED_pn-aktualizr' to '1' in local.conf 42# can be enabled manually by setting 'PTEST_ENABLED:pn-aktualizr' to '1' in local.conf
43PTEST_ENABLED = "0" 43PTEST_ENABLED = "0"
44 44
45SYSTEMD_PACKAGES = "${PN} ${PN}-secondary" 45SYSTEMD_PACKAGES = "${PN} ${PN}-secondary"
46SYSTEMD_SERVICE_${PN} = "aktualizr.service" 46SYSTEMD_SERVICE:${PN} = "aktualizr.service"
47SYSTEMD_SERVICE_${PN}-secondary = "aktualizr-secondary.service" 47SYSTEMD_SERVICE:${PN}-secondary = "aktualizr-secondary.service"
48 48
49EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release ${@bb.utils.contains('PTEST_ENABLED', '1', '-DTESTSUITE_VALGRIND=on', '', d)}" 49EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release ${@bb.utils.contains('PTEST_ENABLED', '1', '-DTESTSUITE_VALGRIND=on', '', d)}"
50 50
@@ -52,7 +52,7 @@ GARAGE_SIGN_OPS = "${@ d.expand('-DGARAGE_SIGN_ARCHIVE=${WORKDIR}/cli-${GARAGE_S
52PKCS11_ENGINE_PATH = "${libdir}/engines-1.1/pkcs11.so" 52PKCS11_ENGINE_PATH = "${libdir}/engines-1.1/pkcs11.so"
53 53
54PACKAGECONFIG ?= "ostree ${@bb.utils.filter('SOTA_CLIENT_FEATURES', 'hsm serialcan ubootenv', d)}" 54PACKAGECONFIG ?= "ostree ${@bb.utils.filter('SOTA_CLIENT_FEATURES', 'hsm serialcan ubootenv', d)}"
55PACKAGECONFIG_class-native = "sota-tools" 55PACKAGECONFIG:class-native = "sota-tools"
56PACKAGECONFIG[warning-as-error] = "-DWARNING_AS_ERROR=ON,-DWARNING_AS_ERROR=OFF," 56PACKAGECONFIG[warning-as-error] = "-DWARNING_AS_ERROR=ON,-DWARNING_AS_ERROR=OFF,"
57PACKAGECONFIG[ostree] = "-DBUILD_OSTREE=ON,-DBUILD_OSTREE=OFF,ostree," 57PACKAGECONFIG[ostree] = "-DBUILD_OSTREE=ON,-DBUILD_OSTREE=OFF,ostree,"
58PACKAGECONFIG[hsm] = "-DBUILD_P11=ON -DPKCS11_ENGINE_PATH=${PKCS11_ENGINE_PATH},-DBUILD_P11=OFF,libp11," 58PACKAGECONFIG[hsm] = "-DBUILD_P11=ON -DPKCS11_ENGINE_PATH=${PKCS11_ENGINE_PATH},-DBUILD_P11=OFF,libp11,"
@@ -87,7 +87,7 @@ do_install_ptest() {
87 find ${D}/${PTEST_PATH}/build -name "*.cmake" -or -name "DartConfiguration.tcl" -or -name "run-valgrind" | xargs sed -e "s|${S}|${PTEST_PATH}/src|g" -e "s|${B}|${PTEST_PATH}/build|g" -e "s|\"--gtest_output[^\"]*\"||g" -i 87 find ${D}/${PTEST_PATH}/build -name "*.cmake" -or -name "DartConfiguration.tcl" -or -name "run-valgrind" | xargs sed -e "s|${S}|${PTEST_PATH}/src|g" -e "s|${B}|${PTEST_PATH}/build|g" -e "s|\"--gtest_output[^\"]*\"||g" -i
88} 88}
89 89
90do_install_append () { 90do_install:append () {
91 install -d ${D}${libdir}/sota 91 install -d ${D}${libdir}/sota
92 install -m 0644 ${S}/config/sota-shared-cred.toml ${D}/${libdir}/sota/sota-shared-cred.toml 92 install -m 0644 ${S}/config/sota-shared-cred.toml ${D}/${libdir}/sota/sota-shared-cred.toml
93 install -m 0644 ${S}/config/sota-device-cred-hsm.toml ${D}/${libdir}/sota/sota-device-cred-hsm.toml 93 install -m 0644 ${S}/config/sota-device-cred-hsm.toml ${D}/${libdir}/sota/sota-device-cred-hsm.toml
@@ -118,7 +118,7 @@ do_install_append () {
118 ${D}${systemd_system_unitdir}/aktualizr.service.d/10-resource-control.conf 118 ${D}${systemd_system_unitdir}/aktualizr.service.d/10-resource-control.conf
119} 119}
120 120
121PACKAGESPLITFUNCS_prepend = "split_hosttools_packages " 121PACKAGESPLITFUNCS:prepend = "split_hosttools_packages "
122 122
123python split_hosttools_packages () { 123python split_hosttools_packages () {
124 bindir = d.getVar('bindir') 124 bindir = d.getVar('bindir')
@@ -131,43 +131,43 @@ PACKAGES_DYNAMIC = "^aktualizr-.* ^garage-.*"
131 131
132PACKAGES =+ "${PN}-info ${PN}-lib ${PN}-resource-control ${PN}-configs ${PN}-secondary ${PN}-secondary-lib ${PN}-sotatools-lib" 132PACKAGES =+ "${PN}-info ${PN}-lib ${PN}-resource-control ${PN}-configs ${PN}-secondary ${PN}-secondary-lib ${PN}-sotatools-lib"
133 133
134FILES_${PN} = " \ 134FILES:${PN} = " \
135 ${bindir}/aktualizr \ 135 ${bindir}/aktualizr \
136 ${systemd_unitdir}/system/aktualizr.service \ 136 ${systemd_unitdir}/system/aktualizr.service \
137 " 137 "
138 138
139FILES_${PN}-info = " \ 139FILES:${PN}-info = " \
140 ${bindir}/aktualizr-info \ 140 ${bindir}/aktualizr-info \
141 " 141 "
142 142
143FILES_${PN}-lib = " \ 143FILES:${PN}-lib = " \
144 ${libdir}/libaktualizr.so \ 144 ${libdir}/libaktualizr.so \
145 " 145 "
146 146
147FILES_${PN}-resource-control = " \ 147FILES:${PN}-resource-control = " \
148 ${systemd_system_unitdir}/aktualizr.service.d/10-resource-control.conf \ 148 ${systemd_system_unitdir}/aktualizr.service.d/10-resource-control.conf \
149 " 149 "
150 150
151FILES_${PN}-configs = " \ 151FILES:${PN}-configs = " \
152 ${sysconfdir}/sota/* \ 152 ${sysconfdir}/sota/* \
153 ${libdir}/sota/* \ 153 ${libdir}/sota/* \
154 " 154 "
155 155
156FILES_${PN}-secondary = " \ 156FILES:${PN}-secondary = " \
157 ${bindir}/aktualizr-secondary \ 157 ${bindir}/aktualizr-secondary \
158 ${libdir}/sota/sota-secondary.toml \ 158 ${libdir}/sota/sota-secondary.toml \
159 ${systemd_unitdir}/system/aktualizr-secondary.service \ 159 ${systemd_unitdir}/system/aktualizr-secondary.service \
160 " 160 "
161 161
162FILES_${PN}-secondary-lib = " \ 162FILES:${PN}-secondary-lib = " \
163 ${libdir}/libaktualizr_secondary.so \ 163 ${libdir}/libaktualizr_secondary.so \
164 " 164 "
165 165
166FILES_${PN}-sotatools-lib = " \ 166FILES:${PN}-sotatools-lib = " \
167 ${libdir}/libsota_tools.so \ 167 ${libdir}/libsota_tools.so \
168 " 168 "
169 169
170FILES_${PN}-dev = " \ 170FILES:${PN}-dev = " \
171 ${includedir}/lib${PN} \ 171 ${includedir}/lib${PN} \
172 " 172 "
173 173