summaryrefslogtreecommitdiffstats
path: root/recipes-test/demo-network-config/primary-network-config.bb
diff options
context:
space:
mode:
authorPhil Wise <phil@advancedtelematic.com>2018-03-19 16:31:31 +0100
committerPhil Wise <phil@advancedtelematic.com>2018-03-19 16:31:31 +0100
commitfc8f9b4b1721a029a30bf41e6086cfbff085089d (patch)
tree1251f3656efe0504f1cefec590fe2a6280a1e5ac /recipes-test/demo-network-config/primary-network-config.bb
parentc3c8d56af6daac3c1eb38118f683db430af48d63 (diff)
downloadmeta-updater-fc8f9b4b1721a029a30bf41e6086cfbff085089d.tar.gz
Add a --secondary-network option to run-qemu-ota
This sets up a simulated 'in vehicle' network. Add support for a Primary node with a DHCP server and a secondary node with a DHCP client.
Diffstat (limited to 'recipes-test/demo-network-config/primary-network-config.bb')
-rw-r--r--recipes-test/demo-network-config/primary-network-config.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-test/demo-network-config/primary-network-config.bb b/recipes-test/demo-network-config/primary-network-config.bb
new file mode 100644
index 0000000..78678a2
--- /dev/null
+++ b/recipes-test/demo-network-config/primary-network-config.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "Sample network configuration for an Uptane Primary"
2LICENSE = "CLOSED"
3
4inherit allarch
5
6SRC_URI = "file://25-dhcp-server.network"
7
8
9FILES_${PN} = "/usr/lib/systemd/network"
10
11PR = "1"
12
13do_install() {
14 install -d ${D}/usr/lib/systemd/network
15 install -m 0644 ${WORKDIR}/25-dhcp-server.network ${D}/usr/lib/systemd/network/
16}